Skip to main content

Setup Windows 10 Discussion

General • Asked by Chris Oliver

Hi,

I got all the way through this so thanks for the walk through! I run "rails server -b 0.0.0.0" and the server boots fine but when I go to localhost:3000 in the browser, the browser icon spins but the server does not respond. Has anyone seen this before?

For any newcomers experiencing this issue:

Run ifconfig then select the appropriate ipv4 ---> inet addr address for your ethernet adapter (Typically eth0).

Example:

eth0 Link encap:Ethernet HWaddr 30:9c:00:a0:93:b5
inet addr:192.168.1.236 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::d400:af9d:a16e:0000/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Then once you find your local IPV4 you can go to your browser and type your address plus the appropriate port, in my case 192.168.1.236:3000

Which will succesfully connect you to your Ubuntu bash rails server on your local machine!

As for anyone experiencing the issue of rails or gem commands not working after exiting and re-entering bash; you need to ensure you are running shell commands, you can acheive this by running exec $SHELL and possibly the few commands prior as laid out in the Installing Ruby portion of this tutorial.

IMPORTANT UPDATE (9/29/2018):
Per the instructions HERE, nate clarifies something extremely important regarding switching users via su. In order to succesfully execute .profile you must use su - user, where su simply switches users, while su - ... is an alias to su user --login || su user -l which then allows you to succesfully execute gem, rails, and bundler commands whereas they would normally be unavailable (command not found). This is a nicer way of doing things, rather than my solution of running exec $SHELL every time, one less command! Woohoo!

Cheers!

As of 9/28/2018


I've worked it out now. It seems that thin was the problem. I switched to webrick and the app now runs perfectly. I don't exactly no what the problem was with thin but this solution works for now!


So cool. I have been waiting for you to write this :)


This is great tut- based on it I installed rails 5 and ruby 2.3.1. created new test app and after rails -s I have something like this: => Booting Puma
=> Rails 5.0.0 application starting in development on http://localhost:3000
=> Run `rails server -h` for more startup options
Exiting
/root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rb-inotify-0.9.7/lib/rb-inotify/watcher.rb:74:in `initialize': Invalid argument - Failed to watch "/root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/locale": the given event mask contains no legal events; or fd is not an inotify file descriptor. (Errno::EINVAL)
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rb-inotify-0.9.7/lib/rb-inotify/notifier.rb:190:in `new'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rb-inotify-0.9.7/lib/rb-inotify/notifier.rb:190:in `watch'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rb-inotify-0.9.7/lib/rb-inotify/notifier.rb:204:in `watch'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/linux.rb:32:in `_configure'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:45:in `block in configure'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:40:in `each'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:40:in `configure'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:63:in `start'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/backend.rb:28:in `start'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/listener.rb:67:in `block in <class:listener>'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/fsm.rb:120:in `instance_eval'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/fsm.rb:120:in `call'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/fsm.rb:91:in `transition_with_callbacks!'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/fsm.rb:57:in `transition'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/listener.rb:90:in `start'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/evented_file_update_checker.rb:90:in `boot!'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/evented_file_update_checker.rb:61:in `initialize'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/i18n_railtie.rb:59:in `new'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/i18n_railtie.rb:59:in `initialize_i18n'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/i18n_railtie.rb:15:in `block in <class:railtie>'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/lazy_load_hooks.rb:36:in `execute_hook'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/lazy_load_hooks.rb:45:in `block in run_load_hooks'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/lazy_load_hooks.rb:44:in `each'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0/lib/active_support/lazy_load_hooks.rb:44:in `run_load_hooks'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/application/finisher.rb:65:in `block in <module:finisher>'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/initializable.rb:30:in `instance_exec'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/initializable.rb:30:in `run'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/initializable.rb:55:in `block in run_initializers'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:228:in `block in tsort_each'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:431:in `each_strongly_connected_component_from'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:349:in `block in each_strongly_connected_component'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in `each'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in `call'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in `each_strongly_connected_component'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:226:in `tsort_each'
from /root/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:205:in `tsort_each'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/initializable.rb:54:in `run_initializers'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/application.rb:352:in `initialize!'
from /root/myapp/config/environment.rb:5:in `<top (required)="">'
from /root/myapp/config.ru:3:in `require_relative'
from /root/myapp/config.ru:3:in `block in <main>'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/builder.rb:55:in `instance_eval'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/builder.rb:55:in `initialize'
from /root/myapp/config.ru:in `new'
from /root/myapp/config.ru:in `<main>'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/builder.rb:49:in `eval'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/builder.rb:49:in `new_from_string'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/builder.rb:40:in `parse_file'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/server.rb:318:in `build_app_and_options_from_config'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/server.rb:218:in `app'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/server.rb:59:in `app'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/rack-2.0.1/lib/rack/server.rb:353:in `wrapped_app'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/server.rb:124:in `log_to_stdout'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/server.rb:77:in `start'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/commands_tasks.rb:90:in `block in server'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/commands_tasks.rb:85:in `tap'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/commands_tasks.rb:85:in `server'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands/commands_tasks.rb:49:in `run_command!'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-5.0.0/lib/rails/commands.rb:18:in `<top (required)="">'
from /root/myapp/bin/rails:9:in `require'
from /root/myapp/bin/rails:9:in `<top (required)="">'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `load'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `call'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/client/command.rb:7:in `call'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/client.rb:30:in `run'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/bin/spring:49:in `<top (required)="">'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `load'
from /root/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `<top (required)="">'
from /root/.rbenv/versions/2.3.1/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /root/.rbenv/versions/2.3.1/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /root/myapp/bin/spring:13:in `<top (required)="">'
from bin/rails:3:in `load'
from bin/rails:3:in `<main>'
Any ideas what should I do ?

According to this site[1] you can omment out "config.file_watcher = ActiveSupport::EventedFileUpdateChecker" in this file, config/environments/development.rb

[1]:https://github.com/rails/ra...

The main issue here is that inotify has been completely broken in WSL. So even if you disable listeners, tools like Guard won't work. Insiders are soon getting a partial fix, whereby files changed within WSL itself can be watched without errors.

Here's the test. First install inotify-tools, which give you some command line programs to monitor files:

$ sudo apt-get install inotify-tools

Then attempt to watch any file from the command line:

$ touch testfile.txt && inotifywatch testfile.txt
Establishing watches...
Failed to watch ./testfile.txt: Invalid argument

Note that's the same error that rb-inotify reports above.

Github issues:
https://github.com/Microsof...
https://github.com/Microsof...


I get the error like : `sudo: setresuid() [1000, 106, 1000] -> [-1, 0, -1]: Operation not permitted` when I try to create new postgres user. Is it going to be fix in the nearest feature?

why does this blog have no support?
people are facing multiple issues!

Hi, friend! You can install postgres in windows. To connect the app you only need a port of the database (I had the same issue at the beginin).

I'm getting the same error and can't figure out how to get around it. I've tried uninstalling and reinstalling Postgresql to no avail. Any thoughts?


How were you able to get the terminal to let you copy the SSH key so that you could paste it into GitHub? Copy and paste is not working for me using shortcuts or the mouse, and there is no menu that I can see.

RIght click on the Ubuntu icon, go to properties and check the boxes under Edit Options and text selection

I would just suggest taking a look at http://cmder.net/ -- This tool is a terminal lifesaver for me on Windows. It is highly configurable. By default, it adds git and some linux tools to cmd, the default shell it uses, but also allows you to use any shell (MING64, Git Bash, PowerShell, the new Bash/Ubuntu for Windows).

Today I tried getting on with the default Bash for Windows which uses the older cmd terminal, but I went bananas. Cmder gives you the text tools you need!


I run Rubinius on Windows 10 Bash.


When I run "rails new testApp -d mysql" I get back
"Errno::ENOMEM: Cannot allocate memory - sudo -p "

Your user account isn't allowed to install to the system Rubygems."

Anyone have any ideas where I went wrong?


Fixed it - had to do a fresh install of everything from outside of the firewall at my office.

Tried re-installing and now the error I get is
"Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory: /home/barp/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/debug_inspector-0.0.2/ext/debug_inspector
/home/barp/.rbenv/versions/2.3.1/bin/ruby -r ./siteconf20160805-549-tt92si.rb extconf.rb
Cannot allocate memory - /home/barp/.rbenv/versions/2.3.1/bin/ruby -r ./siteconf20160805-549-tt92si.rb extconf.rb 2>&1"


I received an error "There was an error while trying to load the gem "uglifier". Gem Load Error is: Could not find a JavaScript runtime." Any ideas?

Install node.js in the Linux subsystem maybe?


After I close the terminal I lost all the settings that I had installed following this tutorial. I will try install it again but I fear that the same happen again. What should I do to prevent it?

In fact, some commands stoped working since I closed the bash: rails new, rake test, bundle etc.

J. Pablo Fernández

You probably need to reselect the ruby with rbenv or rvm.


I'm able to go through this whole tutorial for Windows 10 bash and get everything listed here working (using rvm currently). I get through all the final steps without error, got a working server, etc...

But I'm trying to follow a basic "hello world" tutorial ( found here: http://iridakos.com/2013/11... ) and when I try "rails generate controller pages" I get: "Error: Command 'rails' not recognized" as well as an info section on "Usage: spring COMMAND [ARGS]" and "Usage: rails COMMAND [ARGS]"

I'm confused as to how it could possibly say 'rails' is not recognized. I can do "rails -v", I can do "rails new", I can do "rails server", etc...

Anyone have any advice? I've tried this like 6 times now (resetting my entire linux subsystem after each failed try) using both rvm and rbenv and I end up stuck at this point every time. Any pointers as to where I'm going wrong would be greatly appreciated...thanks!

I was having this same issue and abandoned my attempt. If someone understands what's at hand here, that would be great.

Not entirely sure on that one. Have you guys tried using rbenv instead?

For me, that was with several attempts on different machines using my preferred rbenv -- I'm going to try RVM and report back.

Curious to hear what you find out. I didn't have any issues personally, but only tested rbenv. Now my Windows 10 install is borked and I haven't had time to fix it so it boots again.

Well, I've tossed and reinstalled WSL from scratch, and tried the RVM install instead. I found that I needed to do `bash --login` to reference my profile (and load rvm) if I left the terminal -- so it might be a good idea to reference that -- apparently the default session is not interactive.

Anyway -- I did not encounter the sticky directory issues while using RVM, but I am still having the same issue as above running generators. I've tried both `rails g scaffold hotdogs good tasty` and `bundle exec rails g scaffold hotdogs good tasty` to no avail.

```
[email protected]:~/hotdogs$ uname -a && rvm -v && ruby -v && rails -v
Linux TIMDESKTOP 3.4.0+ #1 PREEMPT Thu Aug 1 17:06:05 CST 2013 x86_64 x86_64 x86_64 GNU/Linux
rvm 1.27.0 (latest) by Wayne E. Seguin <[email protected]>, Michal Papis <[email protected]> [https://rvm.io/]
ruby 2.2.5p319 (2016-04-26 revision 54774) [x86_64-linux]
Rails 4.2.6
[email protected]:~/hotdogs$ rails generate scaffold dogs good tasty
Version: 1.7.2

Usage: spring COMMAND [ARGS]

Commands for spring itself:

binstub Generate spring based binstubs. Use --all to generate a binstub for all known commands. Use --remove to revert.
help Print available commands.
server Explicitly start a Spring server in the foreground
status Show current status.
stop Stop all spring processes for this project.

Commands for your application:

rails Run a rails command. The following sub commands will use spring: console, runner, generate, destroy, test.
rake Runs the rake command
Error: Command 'rails' not recognized
Usage: rails COMMAND [ARGS]

The most common rails commands are:
generate Generate new code (short-cut alias: "g")
console Start the Rails console (short-cut alias: "c")
server Start the Rails server (short-cut alias: "s")
dbconsole Start a console for the database specified in config/database.yml
(short-cut alias: "db")
new Create a new Rails application. "rails new my_app" creates a
new application called MyApp in "./my_app"

In addition to those, there are:
destroy Undo code generated with "generate" (short-cut alias: "d")
plugin new Generates skeleton for developing a Rails plugin
runner Run a piece of code in the application environment (short-cut alias: "r")

All commands can be run with -h (or --help) for more information.
```

I just wanted to add that using the RVM install, knowing to use `bash --login` when I hop in, and ignoring the usage of any commands that utilize spring (generators, console, rake test :( ), seems to be working relatively fluidly (including the majority of rake tasks).

Obviously those are some big issues, but at least I can clone my working project down and run it currently. My last few attempts with RailsInstaller have been horribly unproductive.

Makes sense with the login shell. I wonder why they changed that, because I don't think that was how it used to be. Going to frustrate a lot of people if they keep that as the default.

Got it!

This guy has a solution https://github.com/Microsof...

```
bundle config --delete bin
rake rails:update:bin
git add bin
```

I've successfully tested it using WSL/Bash on Win10, with the instructions posted above using the RVM install, after running `bash --login` to ensure interactive shell.

I've tried numerous times using both the rvm and rbenv route and end up with the exact same issue as described above every time. I've reset the entire linux subsystem between each attempt.

Seems they've been making some changes to it, one of those being it's not a login shell, so you'll have to do "bash --login" for now. Still other outstanding issues. Maybe they'll get some of them fixed soon.

I posted this in the long chain of comments that follows this thread, I thought I'd add it back up here for you and future folks too.

This guy has a solution https://github.com/Microsof...

```
bundle config --delete bin
rake rails:update:bin
git add bin
```

I've successfully tested it using WSL/Bash on Win10, with the instructions posted above using the RVM install, after running `bash --login` to ensure interactive shell.

I hope this helps you out!

Good to hear! This has to be frustrating.

I had the same problem and followed the fix above. The "rails generate controller welcome homepage" finally worked only to create the "app/controllers/welcome_controller.rb" and the route "get 'welcome/homepage'. Then produces the following error "/home/Username/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/thor-0.19.1/lib/thor/actions/inject_into_file.rb:98:in `binread': Input/output error @ rb_sysopen - /home/Username/MyProject/config/routes.rb (Errno::EIO)" and following several .rbenv file names with error lines. Any ideas?

I saw your post on SO http://stackoverflow.com/qu... but don't have enough rep to comment there, so I'll comment here.

You mention not seeing routes.rb in bash, but seeing the file in Windows, and then proceeding to copy stuff around.

The file path you mention your project to be in is a straight up linux folder (/home/User1/stuff) as opposed to a shared, mounted directory in the Windows system. With this said, I've read that interacting with files on that side (burried in appdata or wherever) of the system from Windows causes problems because of the differences in how files are handled between the systems. So, as you mention in SO, trying to copy those files from Windows will likely lead to difficulties.

I've had success with my projects living in the Windows mount area -- for example:

```
cd /mnt/C/Users/Tim/Desktop
rails new hello_world
etc
```

With the files living there, it is easy to manipulate with Windows or Linux then without causing corruption (the worst of it seems to be line ending issues, which any proper text editor can deal with).

In addition, I was using rvm, instead of rbenv.

Without knowing too much more, I'd give generic recommendations akin to "reboot it and see what happens":

- run rbenv rehash
- run bundle install
- run chmod +t -R ~/.bundle
- consider running chown -R user:user /home/user
- cd /mnt/c/Users/User/Desktop && rails new hotdogs && cd hotdogs --- and try creating a controller from there -- pay attention to what happens to the actual output

Hope you find something -- I went through a bit of hell when I tried updating ruby recently, before WSL. I had a perfectly running Ruby 2.2.0 on my system with Rails -- tried upgrading, and went through 3 weeks of frustration in trying to get a working ruby again. The method I posted above has been working really great for me finally, but I don't dare mess with it again -- it's so damned fragile!

Thank very much you for the recommendations. I created a new bash user to install rvm there and follow your recommendations (do you think is OK or I should reinstall the whole subsystem and use rvm this time?). I'll let you know whether it is worked for me too.

Well, finally, the RVM installation with the fix above works fine, like you said! (I found no way to make rbenv installation operational). Thanks a lot!

Hey @excid3:disqus -- You might want to consider noting some of this stuff in the Windows specific guide, unless you are in fact seeing people successfully using rbenv. Right now the guide says rbenv is the recommended way, but I haven't been able to get it to work on WSL without issues. If you know how, that information would also be appreciated :)

I used rbenv just fine when I initially set things up. My Windows 10 install got corrupted so I need to reinstall it and try this again sometime to see how things have changed.


THIS IS AMAZING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I love you <3

I agree with Anthony on this. I have the best of both worlds (solid windows gaming on a ridiculously fast machine and still have an ubuntu bash shell).

This is really perfect Chris. You're awesome.


Excellent!! Thanks so much for this. Up and running without a hitch after first updating to Windows 10 Anniversary. You don't need to be an Insider to update now.

I hope WSL is the real deal...I've had several fits and starts trying to get going with rails on a windows machine.

Suggestion for newbies: rather than create myapp in your linux directory, switch to your windows directory, then create myapp there.

At that point you'll have ready access to work on the myapp files via your IDE

Thus, for final step, type this at the prompt $: cd /mnt/c/Users/you

Then in this director type $: rails new myapp


Got things rolling smoothly with this article. Not sure if anyone else had this issue but ruby took a really long time to install. I thought it was hanging but figured I'd give it a chance and left it running when I went to bed. In the morning it was done so slightly longer than 45 minutes for me!

It definitely can take a while sometimes. Depends on how powerful your computer is and stuff.The good news is you rarely need to do it so once it's done, you will be set for quite a while!

why hours and not minutes?, does not seem like the download was much.

Because compiling Ruby takes a lot of CPU power.


I installed everything. Started the server. Went to the webpage and I got the error:
Cannot load `Rails.application.database_configuration`: No such file or directory @ rb_sysopen - /home/dale/myapp/config/database.yml

Also I tried a cat config/database.yml and received a no file or directory error.

I look in the directory and the file is there.

Frustrating. Can't find a solution. Anyone?

Hey Dale, you'll probably need to create that file if your Rails app doesn't have one. Some details on that file: http://edgeguides.rubyonrai...

I setup a new app and now I get the following message. I know something isn't configured correctly, but I don't know how to determine what it is.

Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

After many times removing everything and starting over I finally resolved the issue. Or should I say this article fixed the problem. http://superuser.com/questi.... I was missing the /var/run/mysqld/mysqld.sock file. It is fixed and I am finally up and running with Rails on Bash on Ubuntu on Windows 10!


Thank you! I would suggest to add to postgresql installation quide, that it is possible to make it running by installing postgres directly on windows (https://www.postgresql.org/... - prefferably version 9.3.

Another issue I had is with Thin rails server. You have to use webrick by setting enviroment variable: `export RACK_HANDLER=webrick` and then run `rails s`

PS: I am going to try to develop our application on windows with this setup, I will post my experience then. Our application is for chess players and tournament organisers - https://www.swips.eu

Did you configure anything after the postgresql installation? I tried to follow the instruction here: https://github.com/Microsof... but it didn't work for me. Do you have any tips/comments that could help? Thanks

BTW.. I did a standard postgresql install on windows and didn't do anything special in the linux side.. my rails app in rails can talk to the postgresql server running in windows.. localhost points to the same place linux and windows..

Thanks for letting me know! I'll go and try this again in the future. Maybe I just messed something up

Hi, I have mysql installed on windows. Do I need to install it separately on Linux Subsystem? Thanks


Unfortunately as of now, when running "sudo -u" there is a bug in the Windows Bash which states: `sudo: setresuid() [1000, 1000, 1000] -> [-1, 0, -1]: Operation not permitted`

Official bug here: https://github.com/Microsof...
Of course you can work around that by using `sudo su USER`.

Otherwise a really nice tutorial with good hints (especially the `chmod +t -R ~/.bundle` one)! Million thanks!


I seem to have trouble sending http requests from my rails server on my windows 10 ubuntu subsystem, whereas people working on their OSX or normal linux have no such problem even with the same code. I keep getting a Net::OpenTimeout (expiration expired) exception no matter what type of http request I do. Has anyone experienced this as well and does anyone know why this might be happening?


@petertruchan:disqus How exactly did you get the postgresql installation to work? I followed the instruction i found here: https://github.com/Microsof... but it didn't work. Any tips/comments would be appreciated. Thanks


Hi!. I have a problem running a rails server. It's seems that a Thin Server is up and running, but not listening on port 3000

This picture will show you my situation. Please help me!.


hey .. did all the things till the final step /
i had some problem so closed the bash screen and turned on again
now when i type ruby -v .. its says it to install same goes for rails everything

so .. far i dnwld everythng is gone ah ???

i dont understand help me

it took nearly 4 hrs fr me to reach final step

It's likely that everything is installed but your terminal didn't automatically load rbenv again. Double check and make sure that you followed all the rbenv lines correctly to echo the lines into your .bashrc file.

i used RVM to install

is that a problem ????

I had the same problem.... this worked for me:
/bin/bash --login

after that I could use ruby -v, rails -v, even rails server
hope it helps :)
BTW I also used rvm

So, today I found something better.... Open up the launcher of the bash and go to the properties.... change the target to "C:\Windows\System32\bash.exe ~ -c "/bin/bash --login"... after this you do not have to use the solution from previous comment every time you launch it.... This works automatically... It's based on the fact that normally you launch a non-login session, however, with these settings you, on the other hand, run a login session..... If you want to know more, read these threads http://askubuntu.com/questi... and https://github.com/Microsof...

Hopefully that default changes in Windows as that's unexpected behavior from anyone who is used to opening bash with a login shell automatically on any Linux install.


great article , someone know how to install solidus ecommerce on w10 ussing bash ubuntu? thks


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/home/rakis/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/byebug-9.0.6/ext/byebug
/home/rakis/.rbenv/versions/2.3.1/bin/ruby -r ./siteconf20161113-24750-68ud34.rb
extconf.rb
Cannot allocate memory - /home/rakis/.rbenv/versions/2.3.1/bin/ruby -r
./siteconf20161113-24750-68ud34.rb extconf.rb 2>&1

Gem files will remain installed in
/home/rakis/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/byebug-9.0.6 for
inspection.
Results logged to
/home/rakis/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/extensions/x86_64-linux/2.3.0-static/byebug-9.0.6/gem_make.out

An error occurred while installing byebug (9.0.6), and Bundler cannot
continue.
Make sure that `gem install byebug -v '9.0.6'` succeeds before bundling.
run bundle exec spring binstub --all
bundler: command not found: spring
Install missing gem executables with `bundle install`


Brilliant - all worked v smoothly, like someone else said installing ruby 2.3.1 took ages. You may also need to install rmagick - to do this type sudo apt-get install libmagickwand-dev imagemagick


Beluan Fil Joseph Qu

I got the problem, i'm following your tutorial, but this result after running rails new myapp -d mysql

There was an error while trying to write to
`/home/user/.bundle/cache/compact_index/rubygems.org.443.29b0360b937aa4d161703e6160654e47`.
It is likely that you need to grant write permissions for that path.
run bundle exec spring binstub --all
bundler: command not found: spring
Install missing gem executables with `bundle install`


so how do we find the root directory where all the created apps are located?

It will be here: "C:\Users\Your Name\AppData\Local\lxss" to access your projects you will navigate to: "C:\Users\Your Name\AppData\Local\lxss\home\then your new Ubuntu username"


J. Pablo Fernández

Any ideas how to access that Ruby binary from Windows? For example, how do I use it as the RubyMine Ruby.


J. Pablo Fernández

Serving static files with webrick inside WSL seems to be as slow as it was on Windows. Have anybody experience this? any solutions?


dan setengahmanusia

please explain to me, i still don't understand, why we don't install rails just using railsinstaller, or some simple easy installer else,,

Rails dev environment is not native on Windows, which is why you have to go through all the hassle.


I believe this guy actually reuses some other people's article and copy pasted.After installing ruby-build, when you do an rbenv install a specific version, Bash on Windows cannot create directories for installing the ruby version.

Nope, wrote it myself, but things are constantly changing with Bash on Windows so these instructions break often.

The horror. I might as well Virtualbox the Rails environment and just work from there instead then. Thanks anyways.

Go for it. Like it says at the top of the post, this is for documenting it for Bash on Windows, not other approaches like VirtualBox.


After installing everything correctly, I received a "This site can't be reached" error for localhost:3000

Any suggestions?


ALERT !
© If you're using Windows Subsystem for Linux then there are currently some limitations on file system notifications that mean you should disable the spring and listen gems which you can do by running rails new blog --skip-spring --skip-listen.
http://guides.rubyonrails.o...


I know this is a bit of an older post, but it is one of the few places where someone is doing, more or less, what I'm trying to do. My question is, has anyone successfully done this with jruby? I have tried installing jruby 9000 in my home directory, in the multi-user setup (usr/bin/jruby which are symlinks pointing to /usr/lib/jruby/bin), and using RVM in the home directory. In all cases I get to the point where jruby is installed and seems to run properly, but the gem command simply doesn't work. When I try to run "gem install rails" or "gem install bundler" or "jruby -S gem install..." I get "Unable to download data from https://rubygems.org/ - timed out"


is it possible to use sublime text somehow? Just wondering


Thanks for this.. It was quite helpful.


Dmitrii Evdokimov

As for now this Bash is open for every PC with 64-bit Windows 10 Anniversary Update build 14393 (1607) or later - https://msdn.microsoft.com/...
So I install Ruby 2.4.1 from sources (and run Jekyll 3.4.3).


Incase you're not able to do rake db:migrate with pgsql try this .

I installed pgsql on local windows and not on ubuntu bash
Then did the following:
Go to you config/environments/development.rb and comment out The Line config.file_watcher = ActiveSupport::EventedFileUpdateChecker,
After this run - rails s or rake db:migrate.

This worked for me and is pretty fast too.
Earlier I was using Vagrant (VM) and this (Ubuntu on bash) is faster than vagrant method,
Just my opinion, Hope it helps :)

What version of postgres did you install on windows?

pgsql - 9.6 and rvm 2.4.
Initially I installed pgsql on ubuntu bash, but it didn't work, some error(don't remember it), then i read somewhere that we need to install on windows, so installed on windows and in db.yml added host as localhost.

Doesn't work with rbenv unfortunately. The pg gem won't install: fatal error: libpq-fe.h: No such file. If I run sudo apt-get install libpq-dev it can no longer find the gem file for some reason.

Actually got it working! Woohoo...


It looks like this does not work currently if you've been upgraded to xenial. Specifically, ruby does not appear to install correctly if you close the bash session, and you have to rerun the rvm script every time, in addition to not being able to install the rails gem at all.

so go for rbenv?


When going to locahost:3000 in the browser I get, json response as it it a api:

{"status":500,"error":"Internal Server Error","exception":"#\u003cRuntimeError: Cannot load `Rails.application.database_configuration`:\nCould not load database configuration. No such file - [\"config/database.yml\"]\u003e


I have one problem on install postgresql on create user.
here is command:
[email protected]:~$ sudo -u postgres createuser malin -s
output: sudo: unable to resolve host XMAN
output: sudo: setresuid() [1000, 106, 1000] -> [-1, 0, -1]: Operation not permitted
how can I fixed it? Thank you.


Hi,
can you do a tutorial to explain how it's possible to configure rubymine to edit a project? (project in ubuntu /home/User). I would like to use Rubymine i have install on windows to edit code in ubuntu subsysteme.

Thanks a lot!

did you get the answer for this?


Chris it would be interesting to update the tutorial for Windows 10 Creators Update considering the many new updates and improvements the Windows Subsystem for Linux has received! ;) https://blogs.msdn.microsof...

I will try doing that! I've gotta get my Windows 10 install back working again. :S

Chris you should add explicitly which version of Windows 10 (1511, 1607, 1703, ecc) this guide curretly refers to.
Anyway, news: Ubuntu finally on the Windows Store: https://www.microsoft.com/e...


My install works fine until 'gem install bundler' when I get this error:'/home/james/.rbenv/versions/2.4.0/bin/ruby: symbol lookup error: /home/james/.rbenv/versions/2.4.0/lib/ruby/2.4.0/x86_64-linux/socket.so: undefined symbol: parse_numeric_port'.
I'd appreciate any help as I really want to get WSL to work.

rvm works


Hello,

Thanks for the tutorial. It really helped me to get my basic setup up and running.
Thou I did have to fiddle around to get a few things working.
I should note that 5/14/17 I was not able to do

sudo -u postgres createuser YOURUSER -s

instead I had to use

sudo sudo -iu postgres createuser YOURUSER -s

due to -u not working at the time on WSL. Also I had to start the postgresql service before creating the user with

sudo service postgresql start

Hope this comments help people trying to install it later.

Thanks again for all your help and to all the RoR community, I just spent the last few days until I had my successful attempt at installing everything I wanted on WSL (yeah there were 4, I am now familiar with lxrun.exe /uninstall /full and lxrun.exe /install to reset the entire linux subsystem :P).

PS:
I would like to see added to the tutorial some information on installing MongoDB. For the moment I will just leave the link to the official tutorial https://docs.mongodb.com/ma... small comment though there are problems starting mongodb as a service so for now the only way I have found is to use sudo mongod. Also, remember to run mkdir /data/db before starting the database (that last bit is required but it is not included in the official tutorial from mongo).


The source on my machine does not have the same path ~/.rvm/scripts/rvm

Mine is @: /usr/local/rvm/scripts/rvm

Also, The source is not persisting after exiting the terminal. And finally, it's failing when I try to start the rails server.


edit: got it working in the end, lots of patience required :)

Hello, thanks for the tutorial, however, I'm just trying to install rbenv and it has already taken 1 hour of waiting, it seems it is stuck on 'installing ruby-2.4.0...'. Should I just cancel and start afresh with rvm?

what did you do? I have same issue. Another comment mentioned he left it over night and was ready in the morning. It is crazy it takes this long. Cant imagine ruby being a huge program.

I am on a haswell cpu i5, 2 cores 4 threads. CPU and HD have been sitting at 1-2% now for about 24 hours. Not feeling like this will improve anytime.


Francisco Javier Vallés Johnso

I just want to share how I was able to install postgresql 9.5.
First, after running "sudo apt-get install postgresql-common postgresql libpq-dev" I got the error:

"http://archive.ubuntu.com/u... xenial-updates/main amd64 postgresql-client-9.5 amd64 9.5.7-0ubuntu0.16.04 Hash Sum mismatch"

So, as the console sugested, I executed it again adding "--fix-missing" and it worked.

Next, running "sudo sudo -u postgres createuser username -s" throwed the error:

"psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?"

which I solved by running "sudo pg_ctlcluster 9.5 main start".

Finally, trying to run "rails db:create" I got the error:

"new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)"

The solution for this was running:
- sudo sudo -u postgres psql
- UPDATE pg_database SET datistemplate = FALSE WHERE datname = 'template1';
- DROP DATABASE template1;
- CREATE DATABASE template1 WITH TEMPLATE = template0 ENCODING = 'UNICODE';
- UPDATE pg_database SET datistemplate = TRUE WHERE datname = 'template1';
- \c template1
- VACUUM FREEZE;

I found all the above solutions searching in Google, but I don't remember the links.

Hope it helps someone and saves them some time.


I have mysql installed on windows. Do I need to install it separately on Linux Subsystem?


How old is this guide? I ask because, as of 6/22/2017 msdn quotes:
"Languages: Javascript/node.js, Ruby, Python, C/C++, C# & F#, Rust, Go, etc.
Services: sshd, MySQL, Apache, lighttpd,"

Suggesting that ruby should have full support now?


Thanks for the tutorial!

Just a note, it's "without further ado", not "without further adieu" 😉


francesco Esposito

ruby-build: definition not found: 2.4.0 ??? help me plz


I get this error anytime i start the rails server or type rails -v

rails-v
/home/word/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/app_loader.rb:40: warning: Insecure world writable dir /mnt/c in PATH, mode 040777
Rails 5.1.3


Great post. The install went fine, including the MySQL server installation, but when I try to connect to the MySQL server, I get the message: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

I uninstalled it (sudo apt-get remove mysql-server) and re-installed. Same error message

If I try to re-install, I get the message that the MySQL server is already installed and is the latest version. Any ideas?

The install process, despite having asked me for the root password, etc., did not automatically start the MySQL server, so the solution is simple: sudo service mysql start


i got a q. now i am o [email protected] does this mean i am on a vertual & so i can not get actual folders and files?


Yuri de Sales Almeida

Is it possible to share folders like vagrant?


I get following error. I followed everything as mentioned in the article.
Looks like mysql db is not created.
Missed any step?

[email protected]:~/myapp$ rake db:create
#<mysql2::error: can't="" connect="" to="" local="" mysql="" server="" through="" socket="" '="" var="" run="" mysqld="" mysqld.sock'="" (2)="">
Couldn't create database for {"adapter"=>"mysql2", "encoding"=>"utf8", "pool"=>5, "username"=>"root", "password"=>"******", "host"=>"localhost", "database"=>"myapp_development"}, {:charset=>"utf8"}
(If you set the charset manually, make sure you have a matching collation)
Created database 'myapp_development'
#<mysql2::error: can't="" connect="" to="" local="" mysql="" server="" through="" socket="" '="" var="" run="" mysqld="" mysqld.sock'="" (2)="">
Couldn't create database for {"adapter"=>"mysql2", "encoding"=>"utf8", "pool"=>5, "username"=>"root", "password"=>"*****", "host"=>"localhost", "database"=>"myapp_test"}, {:charset=>"utf8"}
(If you set the charset manually, make sure you have a matching collation)
Created database 'myapp_test'
[email protected]:~/myapp$ mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
[email protected]:~/myapp$

Not sure if you ever got it working, and I don't have a solution really, but here are some thing's I would check.

Make sure the MySQL server is actually running. If so:

Get a visual MySQL Editor, there's alot of them, make sure your database encoding is UTF8, if it's not change it. The Visual Editor just makes it easier to check thing's out. It's a bit more simple than throwing commands into a console.

Check your Firewall, and make sure it's allowing connections on the MySQL servers port/s.

Make sure you have the correct permissions/privileges, both file system permissions, and privileges to access the MySQL service. For example MySQL may have been installed with only root, or admin access allowed. try opening the bash terminal as administrator, if that doesn't work try using sudo prefixed before commands (with, and then without admin privileges on the bash process.)

Sorry I couldn't give you a concrete solution, hope you get it working.


how to open Sublime, and point them to your folders in C:\code


It's very sloooow. Did anybody get this issue with all Rails/Rake commands?


Good post.

I also needed to run the following, prior to installing ruby:
sudo apt-get install -y gcc libssl-dev libreadline-dev zlib1g-dev make


I installed ruby and rails correctly, but when I run my new rails app, my browser cannot connect. I must have missed something obvious somewhere. Has anyone else had this problem?


Nothing wrong! Just had to start the MySQL service: "sudo service mysql start"


Is there anything wrong with just running `sudo apt install rbenv` instead of the shell script? I was having issues with the script. Only the plugins folder was cloned...


Doesn't work with me.
rails aborted!
Don't know how to build task 'v' (see --tasks)
/home/Emad/myapp/bin/rails:9:in `require'
/home/Emad/myapp/bin/rails:9:in `<top (required)="">'
/home/Emad/myapp/bin/spring:15:in `<top (required)="">'
bin/rails:3:in `load'
bin/rails:3:in `<main>'
(See full trace by running task with --trace)


Just wanted to let you know that I just got this up and running! Thankfully I didn't have any issues. Thank you to whoever for putting this together! Great job!!!!


Thanks for tutorial, although I think you should take a moment to say if you have Windows Git you don't really need git install and likewise if you have mySQL already running as a service you don't need that either, just point database.yaml to windows instance.

Bagus, it should be called "software-properties-common" now or "python3-software-properties". Making an update for that.

Alberto, yep. You'll always need libpq-dev to compile the C extension for Ruby to talk to Postgres. 👍


Hey John, not sure why that command doesn't work from you. I just pasted in the RVM installation instructions from their website. I don't use RVM though but as long as you get the gpg keys imported, that's all you need.


Hi,

I just impressed, awesome tutorial.

I love this tutorial.

Thanks


Hey all,
So I got this running a long time ago and haven't had any issues since but now when I run any rails command I get a warning that says:
/home/user/.rbenv/versions 2.5.3/lib/ruby/gems/2.5.0/gems/railities-5.2.2/lib/rails/app_loader.rb:53 warning: Insecurable world writeable dir mnt/c/rails/project

All the stackoverflow answers are to chmod go-w /home/user but this and many derivations of this doesn't work. What else can I try?


@eliot I looked into this a few months ago and just accepted that it wasn't going to go away unless WSL was changed by Microsoft. Details at: https://github.com/Microsoft/WSL/issues/1426.

There appears to be ways to get rid of it but could introduce a security issue... I decided it was probably a bit of OCD on my behalf and to just let it go. I just find chasing these bugs means hours lost where I could actually be writing code. If you do figure out a good way please tell though.

Hi Jay!
Agreed, one can spend many hours trying to figure out the root cause of why certain things happen. In the end I found a "solution". Within the /mnt/c/ folder I rm -rf the original rails folder and then ran, "mkdir rails_sites, rails new....etc" and by deleting the old dir and creating a new one seems to have worked for the time being. It is strange this is the first time I have had any issues with the linux subsystem. Besides this minor hiccup I have really enjoyed it. I will update if I find anything else.


Hi, im using Windows 10 with the WSL, and im trying to set the Ruby Interpreter in RubyMine to the one i install using Chirs guide, using the following route /home/tensai/.rbenv/shims/ruby, the problem is that when it starts to Loading the Enviorment throws a Communication Error?

Can anyone tell how i can properly set my RubyMine to use the ruby install in WSL? using rbenv as the version manager.

I don't use RubyMine, but according to this, you might need to point to the ruby version inside the .rbenv folder instead of the shim. That way rubymine can find the gems directory correctly.

You can read the post here: https://df.tips/t/topic/326/3


Hey having a hard time debugging an error maybe someone has some insight?

gem install bundler
Fetching bundler-2.0.1.gem
/home/dj/.rbenv/rbenv.d/exec/gem-rehash/rubygems_plugin.rb:6: warning: Insecure world writable dir /home/dj/.rbenv/versions in PATH, mode 040777
Successfully installed bundler-2.0.1
Parsing documentation for bundler-2.0.1
Installing ri documentation for bundler-2.0.1
Done installing documentation for bundler after 10 seconds
1 gem installed

this insecure world writeable dir has been plaguing me if I try to set up a DB and run rake db:create or rails db:create it wont allow it to do anything any help is appriciated!


Hey Chris I'm getting the following error:
PG::ConnectionBad (could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
):

Hey Arnas,

Your Postgres server isn't running. I think most people have the best results installing Postgres on Windows and running it there, then having Rails from WSL connect to that.


Try to export PGHOST=localhost to the bottom of your ~/.bashrc file in WSL


Hi, can anyone help me with a problem, I'm using windows 10 I have installed ruby, Ubuntu and WSL. Whenever I run my code in visual studio editor or console, I receive this warning message,
warning: Insecure world writable dir /mnt/c in PATH, mode 040777
Is there any way I can fix the problem?


i have the same problem:
i tried an older version of bundler still no change.
then i've seen this :
gem install bundler -v 2.0.1
Fetching: bundler-2.0.1.gem (100%)
/home/cod/.rbenv/rbenv.d/exec/gem-rehash/rubygems_plugin.rb:6: warning: Insecure world writable dir /home/cod/.rbenv/versions/2.5.7 in PATH, mode 040777
Successfully installed bundler-2.0.1
Parsing documentation for bundler-2.0.1
Installing ri documentation for bundler-2.0.1
Done installing documentation for bundler after 5 seconds
1 gem installed

so i think that your solution chmod +t -R ~/.bundle is not good in my case,
error
chmod: cannot access '/home/cod/.bundle': No such file or directory

any idea for an work around?
thank you

this solved my issue:
add this to the win 10 path variable:
C:\Users\”Your user” \AppData\Local\Packages\CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc\LocalState\rootfs\mnt


Hi Chris,
when I do 'cd'=> and after 'pwd' => home/user_name,
therefore should i change the commands from:
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bashrc
echo 'eval "$(rbenv init -)"' >> ~/.bashrc
exec $SHELL
to:
echo 'export PATH="$HOME/user_name/.rbenv/bin:$PATH"' >> ~/.bashrc
echo 'eval "$(rbenv init -)"' >> ~/.bashrc
exec $SHELL
???


Login or Create An Account to join the conversation.

Subscribe to the newsletter

Join 27,623+ developers who get early access to new screencasts, articles, guides, updates, and more.

    By clicking this button, you agree to the GoRails Terms of Service and Privacy Policy.

    More of a social being? We're also on Twitter and YouTube.