Skip to main content

Rails Application Templates Discussion

General • Asked by Chris Oliver

Gravatar
Hello,

Im getting
Could not find "Procfile" in any of your source paths. Your current source paths are:
/Users/my_user/Documents/dev/my_app/https:/raw.githubusercontent.com/excid3/jumpstart/master
Using this command:

rails new myapp -d postgresql -m https://raw.githubusercontent.com/excid3/jumpstart/master/template.rb
Also tried this one (downloading the repo):
rails new myapp -d postgresql -m template.rb

The installation hung up, and when I interrupted it and tried to do "foreman start", got:
+ERROR: Procfile does not exist

Any help making the template work ?

Best regards,
Leonardo
Gravatar
Hey Leonardo,

If the Procfile didn't exist, I would imagine that the full template didn't run successfully. I've made a handful of extra changes since the episode so you might want to try it again. I still haven't fixed the HTTP version of it so you'll need to use the downloaded repo still.
Gravatar
Hello Chris,

Thanks for you reply, I updated my local jumpstart repository and got another error:
Error connecting to Redis on 127.0.0.1:6379 (Errno::ECONNREFUSED)
But it was because I didnt have Redis server installed, after I installed it, everything worked ok.

Thanks for your help,
Leonardo

Gravatar
Had the same issue with Redis not installed but also needed to install foreman before everything worked like a charm! Thanks Chris!
~Uzi

Gravatar
Hi!

I came across an error when I was trying to generate a scaffold:
(erb):1:in `template': undefined local variable or method `model_resource_name' for #<Erb::Generators::ScaffoldGenerator:0x00007fd4e005ccf8> (NameError)

I had to replace every occurrence of model_resource_name with singular_name in the file lib/templates/erb/scaffold/_form.html.erb in the newly created app folder. 
Example:
<%%= form_with(model: <%= model_resource_name %>, local: true) do |form| %>
becomes
<%%= form_with(model: <%= singular_name %>, local: true) do |form| %>

Best regards,
Mark
Gravatar
Thanks for the heads up! I was working on overriding the scaffolds like I mentioned in the video and this was one of the errors I ran into. I think I already fixed it but forgot to push it up.
Gravatar
Actually, I bet it's just that you're not using the latest version of Rails 5.2 (rc1 and rc2 are what I'm using). I don't think the beta will work because it looks to have changed in this commit: https://github.com/rails/rails/commit/cf56397ccd10174d94f60331e4a55ff765b3485b

"gem install rails --pre" should fix your problem or just update it in your Gemfile to rc2.

Gravatar
Awesome video, thanks for sharing!

Gravatar
Hello. I'm trying to publish only the basic template in Heroku, but getting error: 

Redis::CommandError: ERR max number of clients reached
https://dashboard.heroku.com/apps/parolin-celula/logs

It's working well in my localhost. 

Gravatar
Hey Gustavo,

Sounds like your Redis instance on Heroku has a maximum number of connections. You might need to reduce the concurrency on Sidekiq or something to create less Redis connections (or increase your Redis node).

Gravatar
Hello Chris,

      While scaffolding I am getting undefined method `model_resource_name' .  Did I miss anything?

template': undefined local variable or method `model_resource_name' for #<Erb::Generators::ScaffoldGenerator

Gravatar
Make sure you're using Rails 5.2 when you use the template. We're only going to support that version since it's almost released and we can take advantage of things like ActiveStorage.

Gravatar
Hey @chris, I have a brand new Ubuntu OS install and have installed refresh Ruby 2.5 and Rails 5.2 running 
the new app command as you mention I am getting the following errors. Any idea why this might be? It builds app but seems to fail everything else after...

Sorry... Link here.
https://drive.google.com/file/d/178Krtd3HP499LRzDacuxKKula-P4ea3s/view?usp=sharing

Gravatar
Hey Josh,

Administrate gem just needed updating. Should be fixed now!
Gravatar
That did the job. :) Legend. Thank you.

Gravatar
Hi Chris 
Thanks for your work on this. For someone with low experience, this is massively helpful! 
That said I'm still battling to get it running.
 My local environment is Os X 10.13.6. I have new installs of Rub 2.5 and Rails 5.2.
I've installed yarn, redis, foreman;
but still seem to be having issues with getting Jumpstart to work.

It seems to be something about:
You need to allow webpack-dev-server host as allowed origin for connect-src. 
This can be done in Rails 5.2+ for development environment in the CSP initializer 
config/initializers/content_security_policy.rb with a snippet like this: 
policy.connect_src :self, :https, "http://localhost:3035", "ws://localhost:3035" if Rails.env.development?

Here are the errors:
https://www.dropbox.com/sh/w05wxfunrj71rwp/AAAF-7nlhaIw5XBapoiqnNura?dl=0

Any help you could lend would be greatly appreciated so I can get onto doing your other Series.


Grant

Gravatar
Update: ok it appears to have been an issue with Redis not initiating properly. I reinstalled at it's resolved the issue. 

Gravatar
Thanks for awesome video!
I want to try and follow this tutorial but i have an err when i make a new app.
------------------------------------------------------------

generate  devise:views:bootstrapped 
=> err : Traceback (most recent call last):

-----------------------------------------------------------
i have an traceback err and i have no idea why this is happen?
someone please help me. 
( any hint is okay )


Gravatar
Hey Lee,

You need to include the other lines as well after the error because that's what we use to debug what went wrong. Without it, we can't tell what happened.
Gravatar
Hi Chris

i tried to find out what's the problem,
and i made a code size much smaller to find out the problem.

i just make a code size to a basic size,
and this basic template also didn't work properly,

problem is occurred when start generate something.
i captured the code and terminal lines,

 code & errs :  https://imgur.com/a/no9qOav

( this kind of similar err is occurred when running "jump start :  template.rb" )


Gravatar

Hi Chris, great video and I would love to use this template.

I've been stuck with this issue for ages, please help! 

When I run foreman start ...

|     + 11 hidden modules
07:55:40 webpack.1 | webpack: Compiled successfully.
07:55:48 web.1 | => Booting Puma
07:55:48 web.1 | => Rails 5.2.0 application starting in development
07:55:48 web.1 | => Run rails server -h for more startup options
07:55:57 sidekiq.1 | 2018-06-30T06:55:57.652Z 30469 TID-ov3hhgys5 INFO: Running in ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin17]
07:55:57 sidekiq.1 | 2018-06-30T06:55:57.652Z 30469 TID-ov3hhgys5 INFO: See LICENSE and the LGPL-3.0 for licensing details.
07:55:57 sidekiq.1 | 2018-06-30T06:55:57.652Z 30469 TID-ov3hhgys5 INFO: Upgrade to Sidekiq Pro for more features and support: http://sidekiq.org
07:55:57 sidekiq.1 | 2018-06-30T06:55:57.652Z 30469 TID-ov3hhgys5 INFO: Booting Sidekiq 5.1.3 with redis options {:id=>"Sidekiq-server-PID-30469", :url=>nil}
07:55:57 sidekiq.1 | Error connecting to Redis on 127.0.0.1:6379 (Errno::ECONNREFUSED)
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:344:in rescue in establish_connection'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:328:in
establish_connection'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:99:in block in connect'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:291:in
with_reconnect'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:98:in connect'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:363:in
ensure_connected'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:219:in block in process'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:304:in
logging'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:218:in process'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:118:in
call'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis.rb:274:in block in info'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis.rb:45:in
block in synchronize'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/2.5.0/monitor.rb:226:in mon_synchronize'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis.rb:45:in
synchronize'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/redis-4.0.1/lib/redis.rb:273:in info'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq.rb:113:in
block in redis_info'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq.rb:95:in block in redis'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/connection_pool-2.2.2/lib/connection_pool.rb:65:in
block (2 levels) in with'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/connection_pool-2.2.2/lib/connection_pool.rb:64:in handle_interrupt'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/connection_pool-2.2.2/lib/connection_pool.rb:64:in
block in with'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/connection_pool-2.2.2/lib/connection_pool.rb:61:in handle_interrupt'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/connection_pool-2.2.2/lib/connection_pool.rb:61:in
with'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq.rb:92:in redis'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq.rb:106:in
redis_info'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/lib/sidekiq/cli.rb:80:in run'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/sidekiq-5.1.3/bin/sidekiq:12:in
<top (required)>'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/bin/sidekiq:23:in load'
07:55:57 sidekiq.1 | /Users/jamesweetland/.rbenv/versions/2.5.1/bin/sidekiq:23:in
<main>'
07:55:58 sidekiq.1 | exited with code 1
07:55:58 system | sending SIGTERM to all processes
07:55:58 web.1 | Exiting
07:55:58 webpack.1 | exited with code 0
07:55:58 web.1 | terminated by SIGTERM
Gravatar
Like the error mentions:
07:55:57 sidekiq.1 | Error connecting to Redis on 127.0.0.1:6379 (Errno::ECONNREFUSED)

Make sure you have Redis installed and running. Anytime you have a connection refused for any service like Postgres, MySQL, Redis, etc, it means it's not running. 

Gravatar
haha so obvious! my bad thanks Chris!
Gravatar
You're all good, easy to overlook those things sometimes! :D

Login or create an account to join the conversation.