Ask A Question


You’re not receiving notifications from this thread.

Rails Application Templates Discussion


Im getting
Could not find "Procfile" in any of your source paths. Your current source paths are:
Using this command:

rails new myapp -d postgresql -m
Also tried this one (downloading the repo):
rails new myapp -d postgresql -m template.rb

The installation hung up, and when I interrupted it and tried to do "foreman start", got:
+ERROR: Procfile does not exist

Any help making the template work ?

Best regards,
Hey Leonardo,

If the Procfile didn't exist, I would imagine that the full template didn't run successfully. I've made a handful of extra changes since the episode so you might want to try it again. I still haven't fixed the HTTP version of it so you'll need to use the downloaded repo still.
Hello Chris,

Thanks for you reply, I updated my local jumpstart repository and got another error:
Error connecting to Redis on (Errno::ECONNREFUSED)
But it was because I didnt have Redis server installed, after I installed it, everything worked ok.

Thanks for your help,

Had the same issue with Redis not installed but also needed to install foreman before everything worked like a charm! Thanks Chris!

I came across an error when I was trying to generate a scaffold:
(erb):1:in `template': undefined local variable or method `model_resource_name' for #<Erb::Generators::ScaffoldGenerator:0x00007fd4e005ccf8> (NameError)

I had to replace every occurrence of model_resource_name with singular_name in the file lib/templates/erb/scaffold/_form.html.erb in the newly created app folder. 
<%%= form_with(model: <%= model_resource_name %>, local: true) do |form| %>
<%%= form_with(model: <%= singular_name %>, local: true) do |form| %>

Best regards,
Thanks for the heads up! I was working on overriding the scaffolds like I mentioned in the video and this was one of the errors I ran into. I think I already fixed it but forgot to push it up.
Actually, I bet it's just that you're not using the latest version of Rails 5.2 (rc1 and rc2 are what I'm using). I don't think the beta will work because it looks to have changed in this commit:

"gem install rails --pre" should fix your problem or just update it in your Gemfile to rc2.
Awesome video, thanks for sharing!
Hello Chris,

      While scaffolding I am getting undefined method `model_resource_name' .  Did I miss anything?

template': undefined local variable or method `model_resource_name' for #<Erb::Generators::ScaffoldGenerator

Make sure you're using Rails 5.2 when you use the template. We're only going to support that version since it's almost released and we can take advantage of things like ActiveStorage.
Hey @chris, I have a brand new Ubuntu OS install and have installed refresh Ruby 2.5 and Rails 5.2 running 
the new app command as you mention I am getting the following errors. Any idea why this might be? It builds app but seems to fail everything else after...

Sorry... Link here.

Hey Josh,

Administrate gem just needed updating. Should be fixed now!
That did the job. :) Legend. Thank you.
Hi Chris 
Thanks for your work on this. For someone with low experience, this is massively helpful! 
That said I'm still battling to get it running.
 My local environment is Os X 10.13.6. I have new installs of Rub 2.5 and Rails 5.2.
I've installed yarn, redis, foreman;
but still seem to be having issues with getting Jumpstart to work.

It seems to be something about:
You need to allow webpack-dev-server host as allowed origin for connect-src. 
This can be done in Rails 5.2+ for development environment in the CSP initializer 
config/initializers/content_security_policy.rb with a snippet like this: 
policy.connect_src :self, :https, "http://localhost:3035", "ws://localhost:3035" if Rails.env.development?

Here are the errors:

Any help you could lend would be greatly appreciated so I can get onto doing your other Series.


Update: ok it appears to have been an issue with Redis not initiating properly. I reinstalled at it's resolved the issue. 
Thanks for awesome video!
I want to try and follow this tutorial but i have an err when i make a new app.

generate  devise:views:bootstrapped 
=> err : Traceback (most recent call last):

i have an traceback err and i have no idea why this is happen?
someone please help me. 
( any hint is okay )

Hey Lee,

You need to include the other lines as well after the error because that's what we use to debug what went wrong. Without it, we can't tell what happened.
Hi Chris

i tried to find out what's the problem,
and i made a code size much smaller to find out the problem.

i just make a code size to a basic size,
and this basic template also didn't work properly,

problem is occurred when start generate something.
i captured the code and terminal lines,

 code & errs :

( this kind of similar err is occurred when running "jump start :  template.rb" )

haha so obvious! my bad thanks Chris!
You're all good, easy to overlook those things sometimes! :D

Jumpstart Giving me This error
gsub app/dashboards/announcement_dashboard.rb
/Users/noman/.rvm/gems/ruby-2.4.1/gems/thor-0.20.0/lib/thor/actions/file_manipulation.rb:263:in `binread': No such file or directory @ rb_sysopen - /Users/noman/Projects/UOB/uob/uob/app/dashboards/announcement_dashboard.rb (Errno::ENOENT)


Hmmm, it sounds like Administrate didn't generate a dashboard file for the Announcement model. That's weird.


I also get this error. I tried in WSL and then on a virtual machine running CentOS 7.


Hi, I'm trying to run jumpstart on my Cloud9 IDE.
Installed yarn successfully and generated the app but when trying to run the app it shuts down. It ends like this:

18:30:37 webpack.1 | [25] ./app/javascript/packs/application.js 515 bytes {0} [built]
18:30:37 webpack.1 | + 11 hidden modules
18:30:37 webpack.1 | webpack: Compiled successfully.
18:30:37 sidekiq.1 | exited with code 1
18:30:37 system | sending SIGTERM to all processes
18:30:37 web.1 | - Gracefully stopping, waiting for requests to finish
18:30:37 web.1 | === puma shutdown: 2018-10-03 18:30:37 +0000 ===
18:30:37 web.1 | - Goodbye!
18:30:37 web.1 | Exiting
18:30:37 web.1 | terminated by SIGTERM
18:30:37 webpack.1 | exited with code 0

Any idea on how run the server and see the app running?


Hi Chris,

when deploying to heroku I get the following error:

2018-11-05T20:24:11.935122+00:00 heroku[router]: at=error code=H10 desc="App crashed" method=GET path="/favicon.ico" request_id=faaeeb99-5f62-4354-b05e-b5540d91f459 fwd="" dyno= connect= service= status=503 bytes= protocol=http

Is this a sommon issue with jumpstart and heroku?


You'll have to view the Rails logs on Heroku, not the HTTP logs, to find the actual error.


I'm trying to create my own template using jumpstart as a guide but the command "directory" is not copying the files from my source directory.

I'm working in local in a folder called templates that contains the file template.rb and also a subfolder with config/initializers/better_errors.rb

I'm doing as in jumpstart:

def copy_initializers
  directory "config/initializers", force: true

But the file better_errors.rb is not being copied in the Rails folder. The console log that I get is as follows:

 exist    config/initializers
   identical    config/initializers/application_controller_renderer.rb
   identical    config/initializers/assets.rb
   identical    config/initializers/backtrace_silencers.rb
   identical    config/initializers/cookies_serializer.rb
      create    config/initializers/cors.rb
   identical    config/initializers/filter_parameter_logging.rb
   identical    config/initializers/inflections.rb
   identical    config/initializers/mime_types.rb
      create    config/initializers/new_framework_defaults_5_1.rb
   identical    config/initializers/wrap_parameters.rb

I had to define the source paths

def source_paths

Is it possible to pre-configure rails template to use postgres as a default db, disable sprockets etc?

Of course i can create .railsrc file with following content


But can i hardcode those options in template?


Hi Chris please help
when installing jumpstart it pause on bellow generator
rails generate devise:views:bootstrapped

Please help!!!!


I started a new application using the template from Github and it's been amazing. I have a question though: Since I created the app some changes have been made in the original template repo. How can I keep my app up to date with the template updates?


Rails application templates only work for generating new apps, so you can't get any updates on an existing app with them.

You can read through the changes and apply them to your app though. It's a manual process instead but it will get you updated.


Great Chris, thanks!


Great video!


Hi Chris. Thx for your inspirating work. I am working on Ruby 2.7.1 and Rails After having completed all the steps I get the following error when running 'rails g administrate:install' : " uninitialized constant Administrate::GeneratorHelpers::Find (NameError)" - find_file in generator_helpers.rb:24 Found no solution after googling. DISABLE_SPRING does not help nor bundle exec before the command line ... I have to mention that I didn't change anything in your gemfile. Administrate version : 0.14.0 Thx by advance for your help :-)

Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 82,464+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.