Ask A Question

Notifications

You’re not receiving notifications from this thread.

Bundle issues

Dana Nourie asked in Rails

Hi,

I'm starting the forums tutorials, and I keep get this bundle error. I've tried bundle update and get the same thing:

Bundler could not find compatible versions for gem "sprockets":
In Gemfile:
sass-rails (>= 0) ruby depends on
sprockets (~> 2.0.0) ruby

rails (= 4.2.0.beta1) ruby depends on
  sprockets-rails (~> 3.0.0.beta1) ruby depends on
    sprockets (2.12.2)

Bundler could not find compatible versions for gem "sprockets-rails":
In Gemfile:
sass-rails (>= 0) ruby depends on
sprockets-rails (~> 2.0.0) ruby

rails (= 4.2.0.beta1) ruby depends on
  sprockets-rails (3.0.0.beta1)

Bundler could not find compatible versions for gem "railties":
In Gemfile:
sass-rails (>= 0) ruby depends on
railties (~> 3.1.0) ruby

rails (= 4.2.0.beta1) ruby depends on
  railties (4.2.0.beta1)

Any idea what I need to do to get bundle working?

Thank you!

Reply

I didn't have the rails 4.2.0.beta1 installed. Doi. Nevermind! :-)

Reply

Ha! That will do it. :)

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 81,149+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more.

    © 2024 GoRails, LLC. All rights reserved.