Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup Ubuntu 15.04 Vivid Vervet Discussion

Chris Oliver asked in General

Worked like a charm testing out on 15.04 with the exception I had to change the repository back to utopic for nodejs and had to add the gpg key for rvm.. great article.. thanks

Reply

Awesome! I'll be sure to tweak those soon since the final release comes out soon!

Reply

Minor inconsistency at the top of the post you recommend 14.10 Trusty Tahr. The 14.10 release is actually Utopic Unicorn, and 14.04 LTS is Trusty Tahr.

Reply

Ah! Thanks. You find my copy-paste job from last version. ;)

Reply

I tried to install using rvm but I get this error.

Error running 'requirements_debian_update_system ruby-2.2.1',

showing last 15 lines of /home/bagus/.rvm/log/1428510134_ruby-2.2.1/update_system.log

++ case "${TERM:-dumb}" in

++ case "$1" in

++ [[ -t 2 ]]

++ return 1

++ printf %b 'There has been error while updating '\''apt-get'\'', please give it some time and try again later.

404 errors should be fixed for rvm to proceed. Check your sources configured in:

/etc/apt/sources.list

/etc/apt/sources.list.d/*.list

\n'

There has been error while updating 'apt-get', please give it some time and try again later.

404 errors should be fixed for rvm to proceed. Check your sources configured in:

/etc/apt/sources.list

/etc/apt/sources.list.d/*.list

++ return 100

Requirements installation failed with status: 100.

Reply

Sounds like you've got issues with apt-get running. Other people have had the same issue it looks like so you'll want to make sure that you can run "sudo apt-get update" successfully it seems.

http://stackoverflow.com/qu...

Reply
Thiago Moreira Thiago Moreira

Thanks, perfect work!!!

Reply

It looks like the PPA hasnt' been updated for 15.04 yet. For now, replace that step with "sudo apt-get install nodejs" and you should be fine.

Reply

Some problems before and after install of Ruby 2.2.2 with rbenv on (l)ubuntu 15.04:

1. The Ruby openssl extension was not compiled. Missing the OpenSSL lib?

Solution for me was

sudo apt-get install libssl-dev

2. On an error:

Sorry, you can't use byebug without Readline. To solve this, you need to rebuild Ruby with Readline support. If using Ubuntu, try sudo apt-get install libreadline-dev and then reinstall your Ruby.

Solution for me was

sudo apt-get install libreadline-dev
CONFIGURE_OPTS="--with-readline-dir=/usr/include/readline" rbenv install 2.2.2

Reply

Thanks simple and easy :-)

Reply
sluiper de waal sluiper de waal

Thanks a lot. Awesome guide, worked flawlessly :)

Reply

very good guide and clear steps, it works on my virtual box

Reply
Talal Alobaid Talal Alobaid

I don't know but I almost every time have to " sudo /etc/init.d/postgresql restart
"

Reply
Daniel Benesch Daniel Benesch

I have the same issue ..

Reply
Talal Alobaid Talal Alobaid

The nodejs ppa:chris-lea/node.js sometimes you get the 404 error

it is better just to go with the

---
curl -sL https://deb.nodesource.com/... | sudo bash -

----

then

---
sudo apt-get install -y nodejs

---

this works fine every time

https://github.com/joyent/n...

Reply
Talal Alobaid Talal Alobaid

also for postgresql when creating user some times you get the

---

createuser: could not connect to database postgres: could not connect to server: No such file or directory

Is the server running locally and accepting

connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
---
restart with
sudo /etc/init.d/postgresql restart

and your good to go

Reply
RachelDalton RachelDalton

Many thanks for this great post!

www.cryptextechnologies.com

Reply

What is the advantage of the nodejs you get from the PPA? Ubuntu seems to have nodejs in their repo by default also.

Reply

The difference is just that the PPA gets updated more often (if the maintainer keeps up to date) vs the Ubuntu repo which only gets updated once every major version change. You'll get a stable version of Nodejs, but it will only receive small updates and security fixes, not major version changes.

Reply

many thanks, but i have a problem installing rails with this command: gem install rails -v 4.2.1
this is the result:

ERROR: While executing gem ... (Gem::RemoteFetcher::UnknownHostError)
no such name (https://api.rubygems.org/ap...

please help me to find the solution, thanks again

Reply

You may need 'rbenv rehash' after setting ruby global version.

Reply

Under your "Using rvm" instructions, they require that you be using a 'bash' shell (the commands would not work with a 'tcsh' shell). Also, the curl command errored the first time, requiring the downloading of a gpg key from keys.gnupg.net and then doing it again. Finally, (if you're installing as root, anyway) the path was /usr/local/rvm/scripts/rvm ..not ~/.rvm/scripts/rvm (I typically run as root while doing the initial setups of various services and software on a new machine.)

Reply

Actually, I couldn't get much of anything to work with the rvm setup. So, I went the easy route and just "apt-get install ruby ruby-dev". It's an older version, but I think it has everything I need.

Reply
Stepan Pakholok Stepan Pakholok

Just the best guidance ever, thanks guys!

Reply
Sergey Lukashov Sergey Lukashov

I got error on Ubuntu 15.04 with mysql2:
Gem::LoadError: can't activate mysql2 (~> 0.3.13), already activated mysql2-0.4.1. Make sure all dependencies are added to Gemfile.

But this will help:
http://stackoverflow.com/qu...

Reply

Worked as written for version 15.04. Ready for my rails intro tomorrow, thanks!

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 83,038+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.