Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup Ubuntu 14.10 Utopic Unicorn Discussion

Chris Oliver asked in General

thanks!

Reply
Giorgio Martini Giorgio Martini

zanx!

Reply

Hi, looks like it didn't want to create the database for me with the rake command. I had to log into postgresql and add it manually.

just thought you should know.

Reply
Martin Dimmock Martin Dimmock

Yeah I got this too. I just closed then restarted the terminal and tried again - worked!

I'm a complete nube to the *nix environment, Ruby, etc., having used only Windows since 1990.

Reply

Thanks for the steps. Worked like a charm :)

Reply

Wonderful guide, worked great for me. I was trying to set up a virtual instance on Amazon, first using their Amazon Linux AMI. Scapped two instances after the ruby on rails (dependencies, user rights, missing files, etc bla bla etc) was pretty broken and messy. Started a new virtual instance running Ubuntu instead and followed your steps. Much better. It's quite a lengthy process but in the end everything worked like a charm, thanks to you!

Reply

its saying rvm not found what to do

Reply
Altamiro Junior Altamiro Junior

Execute: gpg --keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3

After: source ~/.rvm/scripts/rvm

Reply

Great tutorial. Thank you very much.

As a side note, PostgreSQL offers repositories for recent Ubuntu versions. In the tutorial, you are using the Ubuntu Precise repository no matter which Ubuntu version one selects at the beginning oof tutorial. After some research I found out that PostregreSQL offers differents repositories depending on the Ubuntu version. That would be nice to add to the tutorial as well, just in case.

http://www.postgresql.org/d...

Reply

Thanks Jason! I think at the time they didn't have anything past precise. I'm glad they got Trusty and Utopic in there!

Reply
Rael Gugelmin Cunha Rael Gugelmin Cunha

Other alternative is to use the RVM PPA (so, automatic updates): https://github.com/rvm/ubun...

Reply
Isaac Andrade Isaac Andrade

Great article! Helped me a ton!

Just an update, the command below is deprecated:

echo "gem: --no-ri --no-rdoc" > ~/.gemrc

now it should be:

echo "gem: --no-document" > ~/.gemrc

Reply

Awesome, thanks for the heads up Isaac!

Reply

All the process went fine but for some reason I cant see the page on localhost:3000.
It´s giving me a "page not available" error.

Last terminal output is:

vagrant@vagrant-ubuntu-trusty-64:~/myapp$ rails server
=> Booting WEBrick
=> Rails 4.2.0 application starting in development on http://localhost:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
[2015-02-14 23:50:43] INFO WEBrick 1.3.1
[2015-02-14 23:50:43] INFO ruby 2.1.5 (2014-11-13) [x86_64-linux]
[2015-02-14 23:50:43] INFO WEBrick::HTTPServer#start: pid=18421 port=3000

Reply

I had the same problem, but only when trying to connect from another machine on my network. Tried from local and it works successfully. How to open up the server other hosts?

Reply

up and running with Rails in less than 2 hours with your tutorial

1000 thank-yous....

Reply

thank you very much for saving my time :D

Reply

Question, for exporting the rbenv, what's the best way to handle both OSX and Ubuntu? Because I use dotfiles for my zsh and want to just have one file for my zshenv.

Reply

I personally store my configs in a Git repo, clone it on each machine, and symlink the configs.

Reply
Hamed Qaderi Hamed Qaderi

Thanks very much! It didn't took even 20 minutes.

Reply
Ricardo Chirino Ricardo Chirino

[SOLVED]
Question here.
Working on a Linux VM using VirtualBox.
I'm configuring Git and I added the key to my settings.

When I run:

ssh -T git@github.com

I get the following message:
rchirino@rchirino-VirtualBox:~$ ssh -T git@github.com
Warning: Permanently added the RSA host key for IP address '192.30.252.130' to the list of known hosts.
Permission denied (publickey).

Any ideas on how to correct this? Also, can I continue the installation steps and fix this later?

Thanks!

Reply
Ricardo Chirino Ricardo Chirino

SOLVED didn't copy my keys in the proper location

Reply

Thanks Chris! These are probably the clearest installation instructions I've read.

Reply

You're welcome! I'm glad I was able to help. :)

Reply

I agree. Totally new and the install process was very confusing when using www.railstutorial.org. Thanks for the clear instructions.

Reply

Вы забыли упомянуть "Terminal" -> Profile -> Parameters profile -> Heading and command -> Tick this To start a command as an envelope of an input.

Reply
Shravan kumar Shravan kumar

Thanks!

Reply
Jamrodh Singh Jamrodh Singh

i have a problem....please help me

Reply

When I type:

echo 'export PATH="$HOME/.rbenv/plugins/ruby-build/bin:$PATH"' >> ~/.bashrc
exec $SHELL I get an error message: line 124 unepected EOF while looking for matching '"' and line 125 syntax error unexpected end of file.

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 82,464+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.