All threads / Problem installing Capistrano
Ask A Question

Notifications

You’re not receiving notifications from this thread.

Problem installing Capistrano

Bina Darabzand asked in Rails

I am following Chris's "Deploy Ruby on Rails on ubuntu 18.04 ..." But I am stuck at installing Capistrano! command "cap install STAGES=production" gives me the following error :

":$~ cap install STAGES=production
(Backtrace restricted to imported tasks)
cap aborted!
LoadError: cannot load such file -- /usr/lib/ruby/vendor_ruby/Capfile

(See full trace by running task with --trace)"

Can anyone help me with this. I tried all solutions on web, without success.
thanks

Strange, maybe try bundle exec cap install STAGES=production?

Yay! I had the same issue and that worked for me as well. Thanks

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 68,099+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more. Icons by Icons8

    © 2022 GoRails, LLC. All rights reserved.