All threads / Is Something Wrong With Jumpstart?
Ask A Question

Notifications

You’re not receiving notifications from this thread.

Is Something Wrong With Jumpstart?

Tim asked in Gems / Libraries

I've tried to install Jumpstart three times in the last two days and each time all the gems get installed but none of the views or anything else does. When I boot the server it just shows the normal Rails welcome page. Did something change?

They look fine. Everything seems to install okay and there's no errors. The install time did take considerably less time than it normally does so something is not completing. Wondering if it could be something with Spring. I'll try disabling it first as it says in the README. It's always been a very smooth process.

Can you paste the logs in a gist.github.com or something so I can see them all?

Yes, I'll do another fresh install. I suspect that it's probably one of my dependencies is out of date or something like that. It's not a huge deal but I like to use Jumpstart to go through the tutorials. Thanks for your help!

Yeah! I just used it yesterday and didn't have any issues, so I'm curious to see what's going on with your end. I definitely want to keep it up-to-date if anything stopped working!

Chris, the same thing happened again today. Webpacker gets installed and then it just stops where it used to go and run the other installer scripts. Thanks again!

https://gist.github.com/timdisab/d8c34d85b25a29db537e686d43c4d98b

Must be an issue with Spring (it always is shakes fist).

When I run it, it moves right onto the next step:

Webpacker successfully installed 🎉 🍰
You can change application name inside: ./config/application.rb
         run  spring stop from "."
Spring is not running
    generate  devise:install
       rails  generate devise:install
Running via Spring preloader in process 59362
      create  config/initializers/devise.rb
      create  config/locales/devise.en.yml
================================================

Can you try it with DISABLE_SPRING=1 at the beginning? Does that get any further?

I did that yesterday but will try again. I was thinking of updating Homebrew too as there are so many gems in Jumpstart that maybe my packages might be out of date. I did update them a few months ago.

Tried it again. Same thing happens where it stops at:
run spring stop from "."

Maybe I'll try to update the Homebrew Packages next and see if that works. Thanks so much for your help!

Strange! I wonder what's going on.

Another thing you can try is applying Jumpstart to an existing Rails app.

rails new -d postgresql jumppay
cd jumppay
rails app:template LOCATION= https://raw.githubusercontent.com/excid3/jumpstart/master/template.rb

Well, I updated all my Homebrew Packages and Jumpstart still stops in the same place. Luckily I have several existing Jumpstart apps I can add on any new tutorials too. Will also try your suggestion about adding it to an existing app. Cheers!

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 66,029+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more. Icons by Icons8

    © 2022 GoRails, LLC. All rights reserved.