All threads / Trying Out Bootstrap 3.0 Discussion

Ask A Question

Notifications

You’re not receiving notifications from this thread.

Trying Out Bootstrap 3.0 Discussion

Chris Oliver asked in General

Hi, I've been trying to install bootstrap 3 with rails. I keep getting this issue when I run the server:

/.rvm/gems/ruby-1.9.3-p385/bundler/gems/bootstrap-rails-ff63b9787a34/lib/bootstrap-rails/engine.rb:6:in `block in <class:engine>': uninitialized constant Bootstrap::Rails::Engine::Sass (NameError)

Any ideas what could be causing this?

Make sure you didn't put this gem or the sass gem inside the assets group because Rails 4 no longer uses it. If that's not it, paste your Gemfile in a gist and I'll take a look!

Jan Novak ·

Thanks for nice article Chris.
I tried to install the gem adding it to Gemfile and then running bundler. The files got installed into:

C:\RailsInstaller\Ruby1.9.3\lib\ruby\gems\1.9.1\bundler\gems\bootstrap-rails-507323616c5a

is that OK ? I expected them to be in the folder of my application..

thanks a lot

Perfectly good! :) Gems get installed to a location like that when you're in development. It's mostly because you shouldn't ever modify the gem's code, so they don't want to place it in a location where you might be tempted. If you do want to modify the gem, you can fork it and use either the github or path options when specifying a gem to user your own version. This didn't make much sense to me either the first time I used it.

Thanks for this post. Worked like a charm!

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 37,629+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Ruby on Rails tutorials, guides, and screencasts for web developers learning Ruby, Rails, Javascript, Turbolinks, Stimulus.js, Vue.js, and more. Icons by Icons8

    © 2020 GoRails, LLC. All rights reserved.