Skip to main content

Setup MacOS 10.12 Sierra Discussion

General • Asked by Chris Oliver
7bda82dabab0230c50a14594d9b65b3e

Thanks for posting this, Chris. Did you face any issues with Nokogiri when installing the Rails gem?

Ce795239ba5dd2384fc2f88ffaff5451

I haven't actually tested this personally just yet. :) I've got reports it worked great. Are you having issues with it?

7bda82dabab0230c50a14594d9b65b3e

No worries :) Yeah and I think its a Nokogiri issue and its happening while I'm trying build a new app.

B4637bee15ef3152830c9e9050e87df2

Hi Noel, I read your post above with great interest, since i've been trying to debug this issue the last 2-3 hours :(.

Any clues, did you manage to resolve this?

2c785542db600ffabcbbb42ba8131905
Ryan Crispin Heneise

I experienced issues similar to this when installing Nokogiri: https://github.com/SlatherO...

Running
xcode-select --install

prior to installing Nokogiri worked for me.


2bc786d930cd4b6dd5e65f581154dd86

An error occurred while installing libv8 (3.16.14.15), and Bundler cannot continue.
Make sure that `gem install libv8 -v '3.16.14.15'` succeeds before bundling. <<<< don't work after i run bundle install

22e3b2c9b5409367e028f40393423a70

have you solve the problem?
I got encounter the same situation.

F551e5a7f5f861ca6a33a214a926386b

I have solved this problem by those:

brew uninstall v8

gem uninstall libv8

brew install v8

gem install therubyracer

gem install libv8 -v 3.16.14.15 -- --with-system-v8


341430396b1122830a98dd812c633ef8

I have problem with 10.12 sierra :( rbenv not command found
EDIT:
If you want install RoR on macOS 10.12 Sierra you must update Command Line Tools


F62a36ef7d9346b46f7214ba56034e77
Иван Лещинский

This commands helped me:
`brew install libxml2 libxslt`
`gem install nokogiri -v '1.6.6.4' -- --use-system-libraries --with-xml2-include=/usr/local/opt/libxml2/include/libxml2`

85381fdeec46e350a39372d7103248a5

thanks!
this might be preferred though
brew unlink xz; bundle install; brew link xz
read here: http://stackoverflow.com/a/...


B4cbbfc63f6cd5a48ff6e924e5c110f3

make sure you have selected to use Xcode 8 command tools otherwise it won't work


47fcaefa62d7049eba19bd7da4f06092

i get

cat: ˜/.ssh/id_rsa.pub: No such file or directory

2986653d28548b480c72baeb7c7e1ecc

Me too. I eventually figured out to just type a file name with .pub extension and not to follow their instructions.


47fcaefa62d7049eba19bd7da4f06092

solved it i gave the file a name initially...


47fcaefa62d7049eba19bd7da4f06092

ok solved my ssh public key issue but now i m trying to launch mysql and the LaunchAgents in my path i find is a file not a directory...


47fcaefa62d7049eba19bd7da4f06092

and yes if i open the file i do see the entry however my terminal gives me the message...


22e3b2c9b5409367e028f40393423a70

Guys, I have a problem. When I run rbenv install 2.3.1, it stops on this line.
^Cappleui-iMac:~ apple$ rbenv install 2.3.1
Downloading ruby-2.3.1.tar.bz2...
-> https://cache.ruby-lang.org...
Installing ruby-2.3.1...

I installed Xcode not command line but I fully updated it.

Does anyone can help me?

22e3b2c9b5409367e028f40393423a70

Actually, it works. It requires some time. So never mind!


2da31f8250b1ba35ce2bbe7d6d965354

hello there,

I receive an error whenever I try to run the server or use the "rake db:create" command.
I'm using mysql db , tho


Ce795239ba5dd2384fc2f88ffaff5451

There's actually a bug right now (in the last 2 hours) with the thor gem causing problems in new apps. Try this: http://stackoverflow.com/a/...


5f44ed7b05f614d025bf302e1c0ccded

When I try to run rbenv rehash, I get this error:

dyld: Library not loaded: /usr/local/opt/readline/lib/libhistory.6.dylib
Referenced from: /usr/local/bin/bash
Reason: image not found
Abort trap: 6

Not finding anything very helpful right now. Has anyone run into this issue? I just installed macOS Sierra and updated Ruby, Rails, rbenv...


Cf14e2ef45674d2fc7efe847c7e27adc

My English is not so good but your explanation is very clear to me! thanks a lot!


4d1ca3a7ff087217b6dbdac3a9d610fa

I ran the command:

echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bash_profile
source ~/.bash_profile

And now everytime I open a terminal window I am getting the below at the top of my window:

-bash: /Users/robertsaunders/.bash_profile: line 2: syntax error near unexpected token `source'
-bash: /Users/robertsaunders/.bash_profile: line 2: `if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi source /Users/robertsaunders/.bash_profile'

Please help!


0659ff03ee009c9cc1d37884a9f0705e

After installing ruby the version doesn't see to update. does anyone have a suggestion? Running sierra 10.12.2

Audios-MacBook-Pro:shopify Audio$ rbenv install 2.2.5
Downloading ruby-2.2.5.tar.bz2...
-> https://cache.ruby-lang.org...\
Installing ruby-2.2.5...
Installed ruby-2.2.5 to /Users/Audio/.rbenv/versions/2.2.5\
Audios-MacBook-Pro:shopify Audio$ rbenv global 2.2.5\
Audios-MacBook-Pro:shopify Audio$ ruby -v
ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin16]

0659ff03ee009c9cc1d37884a9f0705e

it might be worth adding this to the tutorial-
this needs to be in the last line of ~/.bash-profile

export PATH="$HOME/.rbenv/bin:$PATH"
eval "$(rbenv init -)"

Ed0ab78df1a26c6729f203d9a103442f

Thanks @queglay:disqus , this is useful for me. Much appreciated

But my path was slightly different. I believe the path had changed since you reply

export PATH="$HOME/.rbenv/versions/2.4.2/bin:$PATH"

2e5367f76030328439ecd4add8b19686

Can you explain why we need to do this? Running into the same problem.
Edit: Do'h. I figured it out. I'm using zsh so I had to append it to my .zshrc file.


2825d71fd4d161f7c2f74d34b8892c3c

This helped a lot! I just wish there were an easy way to know if I've just installed the latest versions of everything


72f46a6e78473b8c138d002ba104db0c

I had a problem in the Final Steps; i.e. running rails new myapp -d mysql. The problem was that mysql2 (0.4.5) was not built and installed. It asked me to run 'bundle install'. I then encountered another problem, ssl and encrypto libraries were not found in lib build path (it used /usr/local/Cellar/mysql/5.7.17/lib/). Setting up DYLD_LIBRARY_PATH won't work. To work around this, I copied all /usr/lib/*ssl* and /usr/lib/*crypto* to /usr/local/Cellar/mysql/5.7.17/lib/ and run 'bundle install' again and all worked. Just FYI and thanks.


Eed08bd06796b79719ab737af5421659

Using `rbenv install --list`, the latest version I get is 2.4.0preview2. How does one get the latest stable build like you? Total newb, need some help, I went to the rbenv installation guide on github and followed their instructions. Can we only install what we see in the results from the `rbenv install -l` command?

Ce795239ba5dd2384fc2f88ffaff5451

What I usually do is I run "rbenv install 2.4.0" and it will say hey, this version is missing so update your ruby-build version and give you instructions on how to do that. Then running the install command should succeed then.

Eed08bd06796b79719ab737af5421659

Thanks, that worked! I updated ruby-build, that was the missing part.


B2ead78521fc0ddf03bd33827e96606b

I had to run the rbenv commands with "sudo" otherwise it wouldn't even compile. Something about the -LD flags being wrong. That also forced "sudo" on the gem install command. But otherwise, everything went as advertised.


B8898948ff614ed0738d3d233b0a14e0

was having problems with brew mysql when generating a new app using the mysql ....
error would thrown when 'Installing mysql2 0.4.5 with native extensions'
...
Errno::EACCES: Permission denied @ rb_sysopen -
/Users/MYUSERNAME/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/mysql2-0.4.5/CHANGELOG.md

what I had to do to solve that ...
sudo chown -R $(whoami) /Users/MYUSERNAME/.rbenv/ ....

tried milions things before ...that seemed to work ... I know kinda unwise ..to sudo chown a directory ..but I got no other solution and that worked !!! hope it helps some future frustrated nerds like self ...


4e38576be1bb5040219d1ede2462c9dc

0a726b9461b53c353f6141c37c67e933

Best guide ever !!! Thank you very much !! Absolutely no issues, keep doing stuffs like this !


514ab1bc39a09c188dba2200d5176644

Fantastic!
This tutorial is fantastic, I was able to get my Rails to work!
Thanks to GoRails.com


C19c8ed6c23152e72dd13fad7e9f0876

am nubi, asking for error Access denied for user 'root'@'localhost' (using password: NO)
i've tried update user and pass but this error still appear. what i have to update config/database.yml?

sorry for my bad english


489245f5df6d53ea5a198979fc0bea93

awesome, no issues following this tuto.


E1e6ee73e0835a3d9bfe15cf5363b3a5

i can work with sublime text using this setup?


2986653d28548b480c72baeb7c7e1ecc

These instructions are terrible. It won't accept my SSH key as per the instructions to copy the output of "cat id_rsa.pub". This article is titled "Setup Ruby On Rails on macOS 10.12 Sierra" but they don't work. Please update!


608dbc27d54e1017dfbba92e75ef52f0

Great instructions to get started! everything worked perfectly! Thanks!


05d3e640817ccbb0c688ecc5a8a9c226

I barely know html but I took the course for the command line at learnenough.com and that really helped.
googled around when I got stuck. Downloaded this to do the tutorial by Chris Pine, Learn to Program.


27a7a0f0154bb204ff7c15b873491400

I get this problem after executing gem install rails -v 5.1.4

ERROR: While executing gem ... (Gem::FilePermissionError)

You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory
.
Any suggestions?

2a2c53165eb66252a7f453db9c5497b2

did you ever figure out this problem? i have it too...


5996f8576bd810ad4d543d6c9a2a84cf

great manual, thank you so much!


Login or Create An Account to join the conversation.

Subscribe to the newsletter

Join 18,000+ developers who get early access to new screencasts, articles, guides, updates, and more.

By clicking this button, you agree to the GoRails Terms of Service and Privacy Policy.

More of a social being? We're also on Twitter and YouTube.