Ask A Question


You’re not receiving notifications from this thread.

Setup MacOS 10.9 Mavericks Discussion

Chris Oliver asked in General

Worked for me.
Thank you.


Great walk through, worked perfectly!


Jurgen Coetsiers Jurgen Coetsiers



Ran into the following Error:

The `brew link` step did not complete successfully
The formula built, but is not symlinked into /usr/local
Could not symlink include/mysql
/usr/local/include is not writable.

Any comments or help on this would be most appreciated!


Your problem is:

/usr/local/include is not writable.

I think that should be owned by your user. Mine is

drwxr-xr-x  232 chris  admin   7888 Sep 26 14:24 include

I imagine fixing permissions and reinstalling mysql will do the trick.


I get to the point where I'm loading mysql and then get errors:

launchctl load ~/Library/LaunchAgents/homebrew.mxcl.mysql.plist

launchctl: Couldn't stat("/Users/myusername/Library/LaunchAgents/homebrew.mxcl.mysql.plist"): No such file or directory

nothing found to load

any hints?


(and thanks for this page; I'm looking forward to being up and running soon. Much closer already thanks to you)


Working! Thank you!

Jacinto Revuelta Jacinto Revuelta

great tutorial!!


Thanks a lot, it was always a struggle to get a Rails app to work with `pg` before. Not anymore!

Jared Parmenter Jared Parmenter

Thanks for this!


I'm stuck on the final steps of the installation, I went to create a new rails app. Results are below. I clicked (yes) for everything after the conflict below, and then db:create after

Pears-MacBook-Pro:~ Pear$ rails new tryout -d postgresql


identical README.rdoc

identical Rakefile


identical .gitignore

conflict Gemfile

Overwrite /Users/Pear/tryout/Gemfile? (enter "h" for help) [Ynaqdh]

There was also
Pears-MacBook-Pro:orange Pear$ rake db:create

Could not find gem 'pg (>= 0) ruby' in the gems available on this machine.

Run `bundle install` to install missing gems.

I used homebrew and i'm on mavericks 10.9, i'm trying to find a way to add the rvm, and i've used stack overflow beforehand.

thinknig about just uninstalling everything and resetting everything up if I can't find an answer as i've been working on this for the last few hours.

Any help would be appreciated.



You need to run 'bundle install' as it mentioned there. You set up a new Rails app with a different database. That means you've got a new database adapter gem to use but haven't installed it yet. bundle install will do that for you.


I've never used postgresql in a rails app. I'm getting errors, here is a gist:


not sure how to configure postgres in the yml file


I did the github stuff. never was shown a ssh keycode or whatever.
heres the stuff

jasons-MacBook-Pro:~ prince$ ssh-keygen -t rsa -C ""

Generating public/private rsa key pair.

Enter file in which to save the key (/Users/prince/.ssh/id_rsa): desktop

desktop already exists.

Overwrite (y/n)? n

jasons-MacBook-Pro:~ prince$


When you type "desktop" it thinks you want to use that as the filename. You want to type a full folder and filename. It suggests (and I do too) saving it to /Users/prince/.ssh folder with the name of id_rsa. That's the default and you can go with that because SSH will check there automatically to find keys. If you don't save it there, then you will need to specify where your key is every time you use SSH.


Or just use thoughtbot's laptop repot. (for mac users)


Their repo is fantastic for people familiar with how to setup Ruby. This guide's goal is to teach newcomers the basics.

Lektor  Gannibal Lektor Gannibal

for install Brew i'm need Ruby, for install Ruby i'm need Brew(((


Haha! Actually OSX comes with an older version of Ruby. We use that to install Homebrew so we can make installing a ruby version manager easily.


Hi I got this message after I ran: gem install rails -v 4.2.1

Fetching: i18n-0.7.0.gem (100%)

ERROR: While executing gem ... (Gem::FilePermissionError)

You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory.

can you tell me what I need to do?


This is basically saying that you're not using the rbenv version of Ruby and you're using system Ruby which you don't want to do.

Try restarting your terminal and double check your ran all the commands. The output you should get from the "which ruby" is something like this "/Users/chris/.rbenv/shims/ruby" when it is set up correctly.


just say -> sudo gem install rails -v 4.2.1
It worked fine with that.


hi, i went through these instructions everything worked, then i got to the end and discovered that the program that i am attempting to run is dependant on ruby 1.8.7 instead of 2.2.2. How would I uninstall v 2.2.2?


Don't worry about uninstalling it because you might want to use 2.2.2 in the future. You installed a version manager so you can have multiple copies at once.

Just do this to install 1.8.7:

rbenv install 1.8.7
rbenv global 1.8.7
ruby -v


everything seems to have worked but I can't load http://localhost:3000. I'm using OSX 10.9 and wondering if there s a firewall problem. Is there and how would I fix that?


I am getting the below error..rake db:create

rake aborted!
LoadError: Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` (can't activate mysql2 (~> 0.3.10), already activated mysql2-0.4.1. Make sure all dependencies are added to Gemfile.)

Tasks: TOP => db:create
(See full trace by running task with --trace)

Please help on this issue...


its fixed.. mysql version issue.. thanks friends..

Dishant Kalyani Dishant Kalyani

I am getting this error:how should I fix it?
specified 'sqlite3' for database adapter, but the gem is not loaded. Add `gem 'sqlite3'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).Please be specific.

Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 77,200+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more.

    © 2023 GoRails, LLC. All rights reserved.