Ask A Question

Notifications

You’re not receiving notifications from this thread.

Rails for Beginners Part 4: No template for interactive request

Tony Green asked in General

Noob Rails user here. Can't believe I progressed without any problem through all of Chris's install this and that stuff without any issues at all. Then when I added my first view I get the error: No template for interactive request!
I have checked and double checked everything but I can't locate any typos etc and the naming conventions are exactly as described by Chris. I have been through part 3 and part 4 at least 5 times this morning but to no avail I cannot get a view to render I always get exactly the same error?
I am using:
Ruby version 3.2.2.1
Rails version 7.0.4.3

This is the trace error message:
BlogPostsController#index is missing a template for request formats: text/html

If anyone can shed any light of what I could be doing wrong I would greatly appreciate the help.
Thanks in advance.

Reply

Usually this means you do not have the html.erb file needed. So perhaps either you don’t have it or it is in the wrong location in the file structure. It should be located here:
app/views/blog_posts/index.html.erb

Reply

Thank you for your reply.
Unfortunately my index.html.erb file is located as stated above with no typos so I am really confused as to why I still get the error.

Reply

UPDATE: I shut everything down and then restarted it all again and it is now working which is a shame as I will never know what was actually causing the problem!! Oh well onto the next problem I suppose :)

Reply

Gotcha. I’m happy to hop on a video call and work through it with you if you have the time today. If so, find me in the GoRails Discord, send me a DM and we can set something up.

Reply

My above reply was before I saw your update posted. Glad you got it working though! I’m also still curious as to what the issue was and if it’ll be an ongoing one for you.

Reply

Yes it is a little worrying but I will keep an eye out for anomalies. The only thing I did differently as I am working in a windows environment using VS Code editor is I discovered that I could run a terminal within the editor rather than run a powershell command window outside of it. So that is what prompted me to shut everything down and start a fresh within VS Code. It also allows me to run side by side terminals so I can have one for the server start up and the other for any adhoc rails commands I need to run which is great and helps to see what is going on. Anyway as soon as I did this and refreshed the browser it worked??

Reply

Thanks for you very kind offer of a video call although I have no idea what exactly GoRails Discord is as yet?

Reply

By the way how do I mark this question as solved - I can't see anything to do that?

Reply

Hi Tony, we do not have a marked as solved feature yet. We leave these open.

Discord is a web site or app where you can chat with other people in the community. You can add GoRails to join the GoRails community. Here is the link to the GoRails discord channel. https://discord.gg/gorails

Reply

Thank you for your sharing.

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 83,770+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.