All threads / Rails 7.0.0rc1
Ask A Question

Notifications

You’re not receiving notifications from this thread.

Rails 7.0.0rc1

Mountaindog asked in Rails

Been playing around with Rails 7 aphla2 and yesterday they released an RC version. In my Rails 7 test app, which was previously running alpha2, ran bundle update it updated everything to the RC version. Great! Starting the app in the Dev environment bin/dev generates the error below. Anyone else experiencing this? Also, tried using Ruby v3.0.2 and received the same error.

 /Users/xxxxx/.rvm/gems/ruby-2.7.1/gems/railties-7.0.0.rc1/lib/rails/railtie/configuration.rb:96:in `method_missing': undefined method `assets' for #<Rails::Application::Configuration:0x00007f79da9309a8> (NoMethodError)
09:14:56 web.1  | Did you mean?  asset_host

Follow up on my own post:
Uncomment this in the Gemfile:
gem "sassc-rails", "~> 2.1"
ran
bundle update
bin/dev

The server started successfully. :)
Looks like this gem was commented out in Rails 7 alpha2 default new builds.

Thanks Mountaindog, for posting your solution. I had this issue upgrading an alpha2 app to 7.0.0 and I couldn't find a solution anywhere else until reading your post.

I really appreciate it.

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 70,078+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more. Icons by Icons8

    © 2023 GoRails, LLC. All rights reserved.