Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup Ubuntu 13.10 Saucy Salamander Discussion

Chris Oliver asked in General

Hi, I got this error when entered this command:
sudo -u postgres createuser aaa -s
"could not change directory to "/root": Permission denied"

Reply

Are you a regular user or root when you ran this? I found this when googling it http://www.postgresql.org/m...

Reply

I am new to both ruby and ubuntu and am just wondering where the default directory is for the config/database.yml? Apologies in advance if its quite simple

Reply

It's located inside your Rails application. It will be generated when you run the "rails new" command.

Reply

Great guide for a *nix n00b like me!!

Only one issue, the "add-apt-repository" stuff was reporting "command not found" so I had to search elsewhere to sort that.

But again, thanks my friend, best guide ever :)

Reply

Thanks Rich! Did you have to install the python-software-properties or software-properties-common package(s)? Also which version of ubuntu were you on? I'm surprised it didn't come with Ubuntu 13.10

Reply

if i copy a new rails app and then cd in and type bundle install, it says "The program 'bundle' is currently not installed. You can install it by typing:

sudo apt-get install ruby-bundler"

how can i get it work.
infact doing rails on a new folder says i got to install rails using"sudo apt-get install rails". why like this?
(things were easier with windows)

Reply

okay it seems i did all this in a new tab wch was causing it to behave that way. but i got reasons to believe when i start my comp the next time, that's what i will get when i try starting the app.

Reply
martian packets martian packets

Setting up LAMP, PHP, and Ruby/Rails on an Amazon EC2 instance, running Ubuntu:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

so this is cool. Installing liquid template (Shopify's templating language / framework), drupal, wordpress, and other options. Be fun to set up an old-skool slash-dot server maybe later.

Sound interesting to anyone? If so I'll post my ongoing results here. So far -- stumbles over Amazon's documentation on getting started... but once you have your instance up, everything is straight out of the web, As Amazon claims, it is like having the server in front of you, So (not to beat a dead horce here) It is as if I have my work server here on my coffee table which works for me!
Oh yeah my micro-instance is free for 12 months while I try to do something with it ;)

Reply

Sure! I'd love to hear how it goes.

Reply

You should have told us how to click "Ok" in terminal. :D

Reply

Hi Chris, thanks for the tutorial. I'm new to ruby on rails and is currently trying to set it up on ubuntu 13.10. I've gotten as far as setting up the postgresql but i keep getting this:

try wget --help for more options
gpg: no valid open PGP data found

after typing :

sudo sh -c "echo 'deb http://apt.postgresql.org/p... precise-pgdg main' > /etc/apt/sources.list.d/pgdg.list"
wget --quiet -O - http://apt.postgresql.org/p... | sudo apt-key add -

What do i do?

Reply

You're welcome! Make sure you run the wget command exactly as it is written. Missing a "- " can cause it to fail. If you need to, download the file yourself, and run

sudo apt-key add ACCC4CF8.asc

where ever you download it to.

Reply

Hey thanks for posting this! I set up a user with full permissions on my Linode VPS and then disabled root access for security reasons. Maybe for that reason I am getting "rbenv not found" after I type "rbenv install 2.1.0". Any ideas?

Reply

If you're getting rbenv not found, then go back and run the echo lines to make sure that rbenv is added to your user's bashrc. That's what makes rbenv and all the rubies you install available to that user.

Reply

Thanks for this great article. I'm a newbie and moving pretty slowly in getting the environment set up, so this really helps. At this point, it looks like I have Ruby and Rails installed, I've set up myapp and done the "rails server" command at the end, but the http://localhost:3000 doesn't show me anything ("Problem loading page" message). Do you have any idea what might be wrong? Thanks!

Reply

Make sure the rails server command is still running. The command will say it is listening on http://0.0.0.0:3000 which means it's running successfully.

Reply
Fernando Rosentalski Fernando Rosentalski

Nice post, you could improve adding imagemagick or graphicsmagick as well

Reply
Hassan Mohamad Hassan Mohamad

How to install script on apache2 ubuntu 13.10

Reply

Rails setup has never been easier! Well done mate - you are legendary!

Reply

very cool, big thanks!

Reply

when i restart terminal it doesn't see ruby anymore :(

Reply

Make sure your ~/.bashrc has the export PATH lines in it for rbenv or rvm (whichever you were using).

Reply

This is the very cool every, Thanks for your nice tuts.

Reply

Everything worked fine until I tried to add test the website (http://localhost:3000). I received an error that stated "no Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb). I ran a trace, but it seems that everything else loaded properly. Do I need to add the rakefile?

Reply

Hey Rico, there should be a Rakefile automatically generated when you create your rails app. What command were you running that gave this error?

Reply
Eduardo D Jr Barrete Eduardo D Jr Barrete

Hi Chris,

I have this error : No binary rubies available for: ubuntu/13.10/i386/ruby-2.1.0.

Reply

Hey Eduardo, I believe that is rvm telling you that you don't have all the necessary to compile from source so it is looking for a binary instead. Double check that you installed all the packages with apt-get and the other parts of the tutorial before that.

Reply
Vitorrio Brooks Vitorrio Brooks

Thanks for that!

Reply

Thank you! :)

Reply
pipevators pipevators

Very helpful guide. Works on my ubuntu 13.10. Thanks!

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 84,256+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.