Ask A Question

Notifications

You’re not receiving notifications from this thread.

Chartkick doesn't load on Heroku?

Adrian DeGus asked in Gems / Libraries

I setup a few charts in my app using Chartkick, which work fine in development but not in production. I have the same "Chartkick is not defined" issue as this guy https://github.com/ankane/chartkick/issues/347 but what fixed it for him didn't for me. I even tried possible fixes found on other SO threads, with no luck.

Anyone have the same problem on Heroku?

Reply

nm, found the fix. I had to include the chartkick js tags into the header of my application layouts while including my other js files at the very end of the body, to prevent breaking my wysiwyg editors.

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 81,149+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more.

    © 2024 GoRails, LLC. All rights reserved.