All threads / ActionCable Production Error - Websocket Handshake 404

Ask A Question

Notifications

You’re not receiving notifications from this thread.

ActionCable Production Error - Websocket Handshake 404

Benjamin Broestl asked in Rails

Hello all,

I've been trying to figure out this actioncable Websocket error I'm getting on production in an AWS EB environment on an Application Load Balancer. It's a 404 error and also Failed to Upgrade Websocket in the logs. I've tried possibly the first 5 pages of google and even Bing results looking for answers. I've also configured the nginx.conf file in many different ways in suggestions. Seems like no one wants to attempt to help on StackOverflow. I've followed Chris's videos and tried it the exact way.

Here's a link to my SO post for more information: https://stackoverflow.com/questions/53566797/actioncable-websocket-upgrade-and-404-error

I appreciate the help and you reading this.

Ben

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 39,376+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Ruby on Rails tutorials, guides, and screencasts for web developers learning Ruby, Rails, Javascript, Turbolinks, Stimulus.js, Vue.js, and more. Icons by Icons8

    © 2020 GoRails, LLC. All rights reserved.