Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup MacOS 10.11 El Capitan Discussion

Chris Oliver asked in General
Shannon Moon Shannon Moon

Rails install failed for me on a new install of el capitan (10.11.6) with this error: libiconv is missing. please visit http://nokogiri.org/tutoria... for help with installing dependencies. I installed nokogiri with gem install nokogiri and then was able to successfully install rails and proceed with the installation.

Reply

Thks for the tutorial but when el open the terminal, it display this

Last login: Sun Aug 7 21:52:21 on ttys000
-bash: /Users/MacBookPro/.bash_profile: line 3: syntax error near unexpected token `source'
-bash: /Users/MacBookPro/.bash_profile: line 3: `if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi source /Users/MacBookPro/.bash_profile'
MacBook-Pro-de-MacBook:~ MacBookPro$

how can I revert or fix it?

regards

Reply
Nadeem Jabbar Qureshi Nadeem Jabbar Qureshi

In El Capitan, you might also need to do `sudo gem install bundler -n /usr/local/bin´.

Please see: https://github.com/bundler/...

Reply

I received the error detailed in the last part of the tutorial, but am unclear on how to update the config/database.yml file

Reply

Hey hey! Some tips:
PLEASE, ADD this IN ARTICLE.

Configuring Git section.
after generating ssh-key you need to do:
eval "$(ssh-agent -s)"
ssh-add ~/.ssh/id_rsa
check this by ssh-add -l

and the following text after cat ~/.ssh/id_rsa.pub
add it to your ssh-key in GitHub account.

cause I were bound by Permission denied problem without this actions

Reply

Still working on OSX 10.11 El Capitan! Tnx!

Reply

So, for me 'gem install rails -v 4.2.6' yielded the error 'ERROR: Error installing rails: ERROR: Failed to build gem native extension.' What fixed it was installing xcode commadline tools with 'xcode-select --install'. Maybe you can add this information to the post or open a troubleshoot section.

Reply

Can anybody help me as i want to install Homebrew and ruby on rails on my Macbook OSX 10.8.5 2 months back i still could install homebrew but now it gives the following error.

Last login: Sat Oct 29 15:02:30 on ttys000

mrrobotas-MacBook-Pro:~ mrrobota$ /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent...."

curl: (22) The requested URL returned error: 404

mrrobotas-MacBook-Pro:~ mrrobota$

Reply

Unable to install rails - getting the following error: ERROR: Error installing rails:
activesupport requires Ruby version >= 2.2.2.
New to this stuff, has anyone had the same issue?

Reply

Hi Nat! did you solve this issue? seems that version 2.4.0 was installed in ~/.rbenv, and when i call `ruby -v`, it references an installation in /usr/bin/ruby

Reply

Thank you so much.

Reply
hannah lee hannah lee

Thanks a lot. It worked fine :D

Reply
Mounika Smitha Mounika Smitha

Best tutorial for beginners.

Reply
Mounika Smitha Mounika Smitha

Best tutorial for beginners!

Reply

Thumbs up.It worked perfectly

Reply

all steps followed till the creation of SSH key. I put your command into Terminal, but nothing happens:

cat ~/.ssh/id_rsa.pub

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 80,973+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more.

    © 2024 GoRails, LLC. All rights reserved.