Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup MacOS 10.11 El Capitan Discussion

Chris Oliver asked in General
raulsergioUS raulsergioUS

This link https://gist.github.com/vpa... helps me a lot with El Capitan

Reply
James Jackson James Jackson

Same here, worked like a dream on El Capitan v10.11.1

Reply

thank you! was really helpful.
the only part that i had a difficulty was that when installing rails, the terminal stopped for a bit so i thought it was causing some problems... :( But worked perfectly and it was so easy to get everything sorted! Thank you so much

Reply

Thanks for the good instructions. I would recommend to install postgres from the Postgres.app for mac: http://postgresapp.com/ and get pgAdmin3 app for mac for querys and stuff: http://www.pgadmin.org/down...

Reply

I have created a video based on this guide at:
https://www.youtube.com/wat...

Reply

Awesome documentation! Thanks!

Reply

why isn't there rvm installation guide?

Reply

I keep getting the following error...

-bash: /Users/macpro/.bash_profile: line 6: syntax error near unexpected token `source'
-bash: /Users/macpro/.bash_profile: line 6: `if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi source /Users/macpro/.bash_profile'

...when trying to run the code to add rbenv to bash. Help please!!

I may have installed newer versions of ruby first before running this code. Not sure if that would complicate things.

Reply

Did you get this fixed? i too am getting this error

Reply
Ningchuan Li Ningchuan Li

# To have launchd start mysql at login:

ln -sfv /usr/local/opt/mysql/*plist ~/Library/LaunchAgents

I think current is
ln -sfv /usr/local/opt/mysql/*.plist ~/Library/LaunchAgents

Reply

Please help me if you had same problem like this. I have a problem with this code "ssh -T git@github.com". When I put this line of code I received this:

Reply

that's because you're in the wrong folder and github doesn't find the publickey, so what you need to do is find the right path, then try again and it will works, at least for me, that was the solution.

Reply

Works great! :)

Reply
YiLong Liu YiLong Liu

Hello guys I hope you are having a good day, I'm accessing to Localhost:3000 , It seems everything is installed correctly, but after I run rails server and copy and paste the url the following message is displayed: We're sorry, but something went wrong(500), do you know what is the reason of this?

Reply
Saurabh Agrawal Saurabh Agrawal

How to install rails gem without docs? Also how to make that default?

Reply

How do you install in China?

ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)

too many connection resets (https://rubygems.global.ssl...

Keep getting this

Reply
The Marionettist The Marionettist

Thanks! Cheers!

Great set-up guidance here for a rapid deployment... took less than 30 for me; by about 2 minutes.

Reply
Moritz von Haacke Moritz von Haacke

Great tutorial

Reply
Kaan L Caglar Kaan L Caglar

Works like a charm! Thanks.

Reply
John Habibi John Habibi

Great walk through! I had to side step over to github to makes sense of establishing a new SSH key, but overall A+++

Reply

Awesome guide, worked like a charm on El Capitan and getting Postgre setup straightaway rather than having that oh S*** moment as I try to deploy to heroku next time was a good finishing touch. Thanks.

Reply
Alejandro Pelaez Alejandro Pelaez

Muchas gracias. Funcionó muy bien en El Capitan 10.11

Reply
Join the discussion
Create an account Log in

Want to stay up-to-date with Ruby on Rails?

Join 83,453+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.