All threads / Setup MacOS 11 Big Sur Discussion
Ask A Question

Notifications

You’re not receiving notifications from this thread.

Setup MacOS 11 Big Sur Discussion

Chris Oliver asked in General

Hi
I get an error:
/.zshrc:2: parse error near `source'
any ideas why?

Followed these steps just after reformatting my mac to OS BigSur and got the following error when I tried creating a new rails app:
sh: node: command not found
sh: nodejs: command not found
Node.js not installed. Please download and install Node.js https://nodejs.org/en/download/
Exiting!

I guess Node doesn't come installed with a mac, so going to see if installing that will resolve the issue.

When I run ruby -v I get the response ruby 2.6.3 instead of ruby 3.0.2. What do you think the problem might be?

For anyone seeing this in the future. I had the same issue and got an error when trying to install rails because it was looking for ruby 2.6.3 which wasn't installed. Solved it my closing and reopening terminal. Might work if you run rbenv rehash as well.

Question: When I run ruby -v I get the response ruby 2.6.3 instead of ruby 3.0.2

Did you run rbenv global 3.0.2?
I don't use rbenv, so this is a guess.
I use chruby which is bit more basic and easier than rbenv. https://github.com/postmodern/chruby

Join the discussion

Want to stay up-to-date with Ruby on Rails?

Join 68,099+ developers who get early access to new tutorials, screencasts, articles, and more.

    We care about the protection of your data. Read our Privacy Policy.

    logo Created with Sketch.

    Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more. Icons by Icons8

    © 2022 GoRails, LLC. All rights reserved.