Marco Beffa

Joined

280 Experience
2 Lessons Completed
0 Questions Solved

Activity

Posted in Setup MacOS 12 Monterey Discussion

I'have problem... with Mac M1 Cannot install PG gem rails :-(, there is a problem...

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory: /Users/***/.rbenv/versions/3.1.2/lib/ruby/gems/3.1.0/gems/pg-1.1.4/ext

/Users//.rbenv/versions/3.1.2/bin/ruby -I /Users/**/.rbenv/versions/3.1.2/lib/ruby/3.1.0 -r
./siteconf20220604-26393-svwfqr.rb extconf.rb
checking for pg_config... yes
Using config values from /opt/homebrew/bin/pg_config
checking for libpq-fe.h... yes
checking for libpq/libpq-fs.h... yes
checking for pg_config_manual.h... yes
checking for PQconnectdb() in -lpq... no
checking for PQconnectdb() in -llibpq... no
checking for PQconnectdb() in -lms/libpq... no
Can't find the PostgreSQL client library (libpq)

Undefined symbols for architecture x86_64:
"_PQconnectdb", referenced from:
_t in conftest-ae9e39.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
checked program was:
/* begin /
1: #include "ruby.h"
2:
3: #include
4:
5: /*top
/
6: extern int t(void);
7: int main(int argc, char *argv)
8: {
9: if (argc > 1000000) {
10: int (
volatile tp)(void)=(int ()(void))&t;
11: printf("%d", (*tp)());
12: }
13:
14: return !!argv[argc];
15: }
16: int t(void) { void ((*volatile p)()); p = (void ((
)()))PQconnectdb; return !p; }
/* end */

Is good question! I am also waiting for an answer.

Posted in Setup Ubuntu 20.10 Groovy Gorilla Discussion

Hi! How are you? When I try this:
curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add
--->
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
OK

Hi! But this work also with rails 6?
I have this error:

vue.runtime.esm.js:640 [Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render functions, or use the compiler-included build.

(found in )
warn @ vue.runtime.esm.js:640
mountComponent @ vue.runtime.esm.js:4022
./node_modules/vue/dist/vue.runtime.esm.js.Vue.$mount @ vue.runtime.esm.js:8402
Vue._init @ vue.runtime.esm.js:5017
Vue @ vue.runtime.esm.js:5092
(anonymous) @ hello_vue.js:26
./node_modules/turbolinks/dist/turbolinks.js.e.dispatch @ turbolinks.js:75
r.notifyApplicationAfterPageLoad @ turbolinks.js:994
r.pageLoaded @ turbolinks.js:948
(anonymous) @ turbolinks.js:872

Does anyone know if the solution proposed by Thomas Bush works with rails 5 or is the code to change much? Thank you I've find the gem 'doorkeeper'!

Yes the app don't work... screenshot :-( . You have solved? I have solved i lost to charge app/javascript/css/application.css

Posted in Setup MacOS 10.12 Sierra Discussion

Grazieee!!!

logo Created with Sketch.

Screencast tutorials to help you learn Ruby on Rails, Javascript, Hotwire, Turbo, Stimulus.js, PostgreSQL, MySQL, Ubuntu, and more. Icons by Icons8

© 2022 GoRails, LLC. All rights reserved.