Anthony Francis

Joined

1,770 Experience
17 Lessons Completed
0 Questions Solved

Activity

Posted in How to use Hotwire in Rails Discussion

Thanks Bryce! - I managed to get link_to working after re-adding rails@ujs. Button_to also works too.

Posted in How to use Devise with Hotwire & Turbo.js Discussion

Has anyone tried to destroy a user on devise via account edit user page?

I get undefined method `users_url' for #Devise::RegistrationsController:0x0000000000ca58
on line --> redirect_to navigation_location

whenever I try to do so.

Posted in How to use Hotwire in Rails Discussion

Has anyones destroy action for an object stopped working? And when clicked, it redirects to the show page without destroying the object?

Posted in How to use Devise with Hotwire & Turbo.js Discussion

Also confirmable not longer works when you remove <%= turbo_include_tags %> from the header. And the “turbo_frame_tag” form will no longer show when you run a frame on a page. And you get routing error when you try to log out a session.

No route matches [GET] "/users/sign_out"

Posted in How to use Hotwire in Rails Discussion

Thanks figured it out! You can also run this.

echo > app/assets/javascripts/libraries/.gitkeep
git add app/assets/javascripts/libraries
git commit -m "Adding app/assets/javascripts/libraries

Posted in How to use Hotwire in Rails Discussion

Same! Has anyone figured out how to deploy yet?

logo Created with Sketch.

Ruby on Rails tutorials, guides, and screencasts for web developers learning Ruby, Rails, Javascript, Turbolinks, Stimulus.js, Vue.js, and more. Icons by Icons8

© 2021 GoRails, LLC. All rights reserved.