Kick buttowski

Joined

100 Experience
0 Lessons Completed
0 Questions Solved

Activity

Posted in Comments With Polymorphic Associations Discussion

I am trying to use commentable with actioncable , but I keep getting the following error
d6f951d17) from Async(default) in 20.73ms: ActionView::Template::Error (undefined method `comments' for #<class:0x007f5cec08b880>):
someone advice me to look for value of comments and I realized is not define
but my question is Is it necessary to define relationship between comment and lets say article class ?

class Comment < ApplicationRecord
belongs_to :commentable, polymorphic: true #, optional: true
belongs_to :article, optional: true <--- this point

validates :body, presence: true, length: {minimum: 5, maximimum: 1000 }
after_create_commit {CommentBroadcastJob.perform_later self}
end

Posted in Edit Data on same page

it doesn't work for me
inline editing combine with polymorphic association

Posted in Subscriptions with Stripe Discussion

Hope all is fine.
I recieve this error
ExecJS::RuntimeError in Listings#index

I did the following
1. ExecJS::RuntimeError in Listings#indexs did not work
2. install gmes, exechs and therubyracer did not work.
3. try to find runtimes.rb and could not
4. I get rid of //= require_tree . error goes away but after awhile it comes back
Could anyone help me to fix it?

Posted in Subscriptions with Stripe Discussion

hope you are fine.I double check my works and all is the same, but I still get error in heroku and not localhos?

Posted in Subscriptions with Stripe Discussion

thanks.
my confusion is why the same code is working in my localhost which is c9.io account but not at heroku?

Posted in Subscriptions with Stripe Discussion

where should I check?
thanks for your attention I am new on this but I am getting better

Posted in Subscriptions with Stripe Discussion

now I get this error
Cannot charge a customer that has no active card

response body is

{error:
{message: "Cannot charge a customer that has no active card"
type: "card_error"
param: "card"
code: "missing"}}

Posted in Subscriptions with Stripe Discussion

oh wowww it is nil
how come? :O

I even used this
heroku config:set PUBLISHABLE_KEY=x SECRET_KEY=y

but why is it still nil?

Posted in Subscriptions with Stripe Discussion

thanks for your fast response. I have the keys at production level too, just they are the test keys.
my application.yml looks like this
stripe_api_key: x
stripe_publishable_key: y
#
production:
stripe_api_key: x
stripe_publishable_key: y

Posted in Subscriptions with Stripe Discussion

Hope everyone is ok.
I have question about my rails app.
I get this error in heroku
Stripe::AuthenticationError (No API key provided. Set your API key using "Stripe.api_key = <api-key>". You can generate API keys from the Stripe web interface. See https://stripe.com/api for details, or email [email protected] if you have any questions.):
yet all is ok in localhost which I use c9.io account.
Does anyone has any idea what is going on?
if more info is needed, I gladly provid
thank you

logo Created with Sketch.

Ruby on Rails tutorials, guides, and screencasts for web developers learning Ruby, Rails, Javascript, Turbolinks, Stimulus.js, Vue.js, and more. Icons by Icons8

© 2020 GoRails, LLC. All rights reserved.